Bug 183335 - ifup-eth does not set wireless options for bridge member interface
ifup-eth does not set wireless options for bridge member interface
Status: CLOSED DUPLICATE of bug 122801
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 06:41 EST by Radek Hladik
Modified: 2014-03-16 22:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 12:05:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Hladik 2006-02-28 06:41:36 EST
Description of problem:
ifup-eth exits after adding interface into bridge and thus does not check
whether the device is wireless and does not set wireless options.

Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Easily

Steps to Reproduce:
1. Prepare these two device configs:
ifcfg-eth_ok:
DEVICE=eth_ok
BOOTPROTO=static
HWADDR=00:0A:EB:A7:E3:A3
IPADDR=0.0.0.0
NETMASK=255.255.255.255
ONBOOT=yes
TYPE=wireless
MODE=master
ESSID=myessid
CHANNEL=13
IWPRIV="mode 3"

ifcfg-eth_bad:
DEVICE=eth_bad
BOOTPROTO=static
HWADDR=00:0A:EB:A7:E3:A3
IPADDR=0.0.0.0
NETMASK=255.255.255.255
ONBOOT=yes
TYPE=wireless
#this is the only difference:
BRIDGE=br_open
MODE=master
ESSID=myessid
CHANNEL=13
IWPRIV="mode 3"

  
Actual results:
ifup eth_ok sets wireless options (this is usual wireless config file)
ifup eth_bad adds interface into bridge but does not set wireless options (mode,
channel,...)

Expected results:

ifup eth_bad should add interface into bridge and set wireless options

Additional info:

I solved the problem with commenting-out command "exit 0" in ifup_eth:
if [ -n "${BRIDGE}" -a -x /usr/sbin/brctl ]; then
      /sbin/ip addr flush dev ${DEVICE} 2>/dev/null
      /sbin/ip link set dev ${DEVICE} up
      /usr/sbin/brctl addif ${BRIDGE} ${DEVICE}
      # Upon adding a device to a bridge,
      # it's necessary to make radvd reload its config
      [ -r /var/run/radvd/radvd.pid ] && kill -HUP `cat /var/run/radvd/radvd.pid`
      #quickfix exit 0
fi

It didn't break anything in my setup but I can guarantee that it wont break
anything in genereal.
Comment 1 Bill Nottingham 2006-02-28 12:05:32 EST

*** This bug has been marked as a duplicate of 122801 ***

Note You need to log in before you can comment on or make changes to this bug.