Bug 122803 - anaconda creates ext2/ext3 partitions incompatible with parted
Summary: anaconda creates ext2/ext3 partitions incompatible with parted
Status: CLOSED DUPLICATE of bug 90894
Alias: None
Product: Fedora
Classification: Fedora
Component: parted   
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-08 08:16 UTC by Keenan Pepper
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Keenan Pepper 2004-05-08 08:16:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
When auto-partition option is selected during install, later parted
cannot handle the partitions created.


Version-Release number of selected component (if applicable):
GNU Parted 1.6.6

How reproducible:
Always

Steps to Reproduce:
1. Wipe hard drive and do clean install of Fedora Core 1
2. Select auto-partition option in anaconda (don't know if manual is
any different)
3. Boot from GNU Parted rescue disk
4. Try to do anything to the new ext3 partitions with parted

Actual Results:  Parted says:
No Implementation: This ext2 filesystem has a rather strange layout!
Parted can't resize this (yet).


Expected Results:  Parted should be able to check/move/resize/etc. the
new partitions.

Additional info:

This is definitely not an ext3-specific issue because I converted the
ext3 partitions to ext2 with tune2fs and parted did exactly the same
thing.
A work-around is to first create the partitions with parted and then
install Fedora into the existing partitions.

Comment 1 Jeremy Katz 2004-05-10 16:05:19 UTC
This is actually just that parted doesn't have support for some of the
newer ext[23] features.

Comment 2 Jeremy Katz 2004-06-25 19:48:23 UTC

*** This bug has been marked as a duplicate of 90894 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:03:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.