Bug 122807 - hotplug firmware loading does not work during init
hotplug firmware loading does not work during init
Status: CLOSED DUPLICATE of bug 112824
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
http://ipw2100.sourceforge.net/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 05:30 EDT by Jukka Ketelaars
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jukka Ketelaars 2004-05-08 05:30:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
During init the ipw2100 (Intet Pro Wireless 2100) driver is unable to
load it's firmware via hotplug. Once the system is started, firmware
loading works fine by doing rmmod ipw2100; modprobe ipw2100.

Version-Release number of selected component (if applicable):
hotplug-2004_04_01-1

How reproducible:
Always

Steps to Reproduce:
1. Compile and install ipw2100 driver according to instructions in URL
2. reboot system
    

Actual Results:  Network adapter is not recognized. dmesg shows the
following:

ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 0.43
ipw2100: Copyright(c) 2003-2004 Intel Corporation
Detected ipw2100 PCI device at 0000:02:02.0, dev: eth1, mem:
0x90000000-0x90000FFF -> e1992000, irq: 5
eth1: Firmware 'ipw2100-1.0.fw' not available or load failed.
eth1: ipw2100_get_firmware failed: -2
eth1: Failed to power on the adapter.
eth1: Failed to start the firmware.
ipw2100: probe of 0000:02:02.0 failed with error -5



Expected Results:  dmesg should have shown the following:

ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 0.43
ipw2100: Copyright(c) 2003-2004 Intel Corporation
divert: allocating divert_blk for eth1
Detected ipw2100 PCI device at 0000:02:02.0, dev: eth1, mem:
0x90000000-0x90000FFF -> e1a1b000, irq: 5
eth1: Using hotplug firmware load.


Additional info:

I fixed this by downloading
http://prdownloads.sourceforge.net/linux-hotplug/hotplug-2004_03_29.tar.gz?download
and copying /hotplug-2004_03_29/etc/rc.d/init.d/hotplug from that
archive to /etc/init.d/hotplug followed by a "chkconfig --add
hotplug". After this the firmware loads fine during init.
Comment 1 Bill Nottingham 2004-05-21 14:36:38 EDT

*** This bug has been marked as a duplicate of 112824 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.