Bug 112824 - [RFE] firmware.agent in future releases
[RFE] firmware.agent in future releases
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://prism54.org/~hvr/firmware.agen...
: FutureFeature
: 122807 126652 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-02 17:19 EST by shrek-m
Modified: 2014-03-16 22:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 15:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2004-01-02 17:19:54 EST
Description of problem:
please add the firmware.agent in future releases

http://prism54.org/~hvr/firmware.agent
http://cvs.sourceforge.net/viewcvs.py/linux-hotplug/admin/etc/hotplug/firmware.agent

/etc/hotplug/firmware.agent
/usr/lib/hotplug/firmware/<firmware_here>


see eg. 
http://prism54.org/cgi-bin/cvsweb/prism54-ng/README?rev=HEAD
section: firmware/hotplug

Version-Release number of selected component (if applicable):
hotplug-2003_08_05-1

How reproducible:
Always

Steps to Reproduce:
1. # hotplug

Actual Results:  AgentName values on this system: ieee1394 net pci
scsi usb

Expected Results:  AgentName values on this system: firmware ieee1394
net pci scsi usb

Additional info:

the prism54-driver is not usable without the firmware.agent
Comment 1 shrek-m 2004-01-26 17:07:35 EST
thanks for  hotplug-2004_01_05-1  in development
AgentName values on this system:
dasd firmware ieee1394 input net pci scsi tape usb


but there is no FIRMWARE_DIR after the update

---------
$ grep FIRMWARE_DIR /etc/hotplug/firmware.agent
FIRMWARE_DIR=/usr/lib/hotplug/firmware
    if [ -f $FIRMWARE_DIR/$FIRMWARE ]; then
        cp $FIRMWARE_DIR/$FIRMWARE $SYSFS/$DEVPATH/data
---------

could you add this directory?
  # mkdir -p /usr/lib/hotplug/firmware
thanks
Comment 2 Bill Nottingham 2004-05-21 14:36:42 EDT
*** Bug 122807 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2004-06-29 01:06:25 EDT
*** Bug 126652 has been marked as a duplicate of this bug. ***
Comment 4 Jukka Ketelaars 2004-08-30 13:43:13 EDT
The problem I described in Bug 122807 which was marked as duplicate of
this bug, has been resolved in latest rawhide. The ipw2100 driver now
works fine during init.
Comment 5 Bill Nottingham 2004-08-30 15:01:09 EDT
Fixed in initscripts-7.70-1.
Comment 6 Jeff Gold 2004-10-02 15:16:43 EDT
Please change bug 122807 so that it is no longer a duplicate of this
one.  Bug 122807 is *not* fixed in initscripts-7.70-1.

I have an x86_64 system with a PCI prism54 device running FC2 on which
I have installed initscripts-7.80-1 and mkinitrd-4.1.11-1 from FC3
test2 and the behavior is unchanged.  Specifically, the network card
cannot start at boot because without hotplug support firmware cannot
be loaded.  Using ifup later brings it up with no problems and can be
used as a work around.

Still, this should be fixed because in many cases it is quite
cumbersome.  For example, I run DNS and DHCP (the machine is
essentially an 802.11g access point) so these services must be
restarted as well.
Comment 7 Bill Nottingham 2004-10-03 23:11:43 EDT
The submitter said 122807 worked for him...
Comment 8 Jukka Ketelaars 2004-10-04 01:21:03 EDT
Yes, bug 122807 has worked for me ever since (I'm now at
initscripts-7.86-1). I'm running FC3t2 up2date up to 2004/10/02.

Note You need to log in before you can comment on or make changes to this bug.