Bug 122824 - GRUB configured with ide-scsi entry preventing CD drive working
GRUB configured with ide-scsi entry preventing CD drive working
Status: CLOSED DUPLICATE of bug 116622
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-08 15:00 EDT by Leon Stringer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leon Stringer 2004-05-08 15:00:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I upgraded from FC1 to FC2 test3. The resulting install included a
GRUB entry which prevented the CD drive from working: I couldn't play
audio CDs (GNOME CD player said "Drive error"), mount /mnt/cdrom
returned "/dev/cdrom is not a valid block device").

The complete GRUB entry for the install was:

title Fedora Core (2.6.5-1.327)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.5-1.327 ro root=LABEL=/ hdc=ide-scsi
rhgb nofb
        initrd /boot/initrd-2.6.5-1.327.img

Removing the "hdc=ide-scsi" entry fixed the problem, I can now play
audio CDs and read and write CDs.

Version-Release number of selected component (if applicable):
grub-0.94-4

How reproducible:
Always

Steps to Reproduce:
Hmmm. Adding/removing the entry is 100% reproduceable. As for
upgrading from FC1 to FC2t3, well I've only done that once.
    

Actual Results:  CD drive operations did not work after upgrade.

Expected Results:  CD drive should have worked.

Additional info:
Comment 1 Jim Cornette 2004-05-09 17:50:55 EDT
I experienced the same result with ugrading from FC1 to FC2T3. I don't
think that the upgrade should tinker too much with the parameters
given to the kernel, bt removing something that is a known change from
the 2.4 kernel to a 2.6 kernel might be a rational choice for smoother
upgrades.
Comment 2 Jeremy Katz 2004-05-10 11:29:45 EDT

*** This bug has been marked as a duplicate of 116622 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.