Bug 1228358 - chmsee won't start
Summary: chmsee won't start
Keywords:
Status: CLOSED DUPLICATE of bug 1238845
Alias: None
Product: Fedora
Classification: Fedora
Component: chmsee
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Yijun Yuan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-04 17:45 UTC by igor.redhat@gmail.com
Modified: 2016-02-14 04:19 UTC (History)
6 users (show)

Fixed In Version: 2.0.2-19.gitd40ff7da.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-19 08:12:10 UTC
Type: Bug


Attachments (Terms of Use)

Description igor.redhat@gmail.com 2015-06-04 17:45:17 UTC
Description of problem:

chmsee doesn't start at all:

$ chmsee 

(process:5481): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '37.0.2' is not compatible with
minVersion >= 22.0
maxVersion <= 33.*


Version-Release number of selected component (if applicable):

$ rpm -q chmsee
chmsee-2.0.2-17.gitd40ff7da.fc22.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Start chmsee from command line

Actual results:

chmsee immediately exits with an error message

Expected results:

chmsee starts

Comment 1 Michal Ambroz 2015-07-17 15:44:18 UTC
+1

As a workaround it is possible to change maxVersion to * in the
/usr/lib64/chmsee/application.ini (resp. /usr/lib/chmsee/application.ini)

Best regards
Michal Ambroz

Comment 2 Hin-Tak Leung 2015-08-15 22:54:21 UTC
Still a problem - I think it was fixed for a while, then broke again when xulrunner is newer than chmsee...

$ chmsee

(process:26564): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '38.0' is not compatible with
minVersion >= 22.0
maxVersion <= 37.*
$ rpm -q chmsee
chmsee-2.0.2-18.gitd40ff7da.fc22.x86_64

Comment 3 Fedora Update System 2015-08-16 04:54:52 UTC
chmsee-2.0.2-21.gitd40ff7da.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/chmsee-2.0.2-21.gitd40ff7da.fc23

Comment 4 Fedora Update System 2015-08-16 04:55:00 UTC
chmsee-2.0.2-19.gitd40ff7da.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/chmsee-2.0.2-19.gitd40ff7da.fc22

Comment 5 Fedora Update System 2015-08-16 04:55:09 UTC
chmsee-2.0.2-19.gitd40ff7da.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/chmsee-2.0.2-19.gitd40ff7da.fc21

Comment 6 lnie 2015-08-17 06:16:50 UTC
chmsee-2.0.2-19.gitd40ff7da.fc22 works

Comment 7 Fedora Update System 2015-08-18 05:13:18 UTC
Package chmsee-2.0.2-21.gitd40ff7da.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing chmsee-2.0.2-21.gitd40ff7da.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13536/chmsee-2.0.2-21.gitd40ff7da.fc23
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-08-19 08:12:10 UTC
chmsee-2.0.2-19.gitd40ff7da.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-08-26 04:33:45 UTC
chmsee-2.0.2-21.gitd40ff7da.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-08-26 16:49:38 UTC
chmsee-2.0.2-19.gitd40ff7da.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Hin-Tak Leung 2015-10-27 20:59:49 UTC
Broke again.

Comment 12 Hin-Tak Leung 2015-10-27 21:00:43 UTC
$ chmsee

(process:9759): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '40.0' is not compatible with
minVersion >= 22.0
maxVersion <= 39.*
[Hin-Tak@localhost FontValidator]$ rpm -q chmsee
chmsee-2.0.2-21.gitd40ff7da.fc23.x86_64
$ rpm -q xulrunner
xulrunner-40.0-1.fc23.x86_64

Comment 13 Yijun Yuan 2016-02-14 04:19:51 UTC

*** This bug has been marked as a duplicate of bug 1238845 ***


Note You need to log in before you can comment on or make changes to this bug.