Bug 1238845 - Needs rebuild against newer xulrunner
Summary: Needs rebuild against newer xulrunner
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: chmsee
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Yijun Yuan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1228358 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-02 19:22 UTC by Hin-Tak Leung
Modified: 2016-04-10 22:30 UTC (History)
5 users (show)

Fixed In Version: 2.0.2-19.gitd40ff7da.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1325714 (view as bug list)
Environment:
Last Closed: 2016-02-14 04:12:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Hin-Tak Leung 2015-07-02 19:22:20 UTC
Description of problem:
chmsee some.chm

(process:23006): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '37.0.2' is not compatible with
minVersion >= 22.0
maxVersion <= 33.*


Version-Release number of selected component (if applicable):
xulrunner-37.0.2-2.fc22.x86_64
chmsee-2.0.2-17.gitd40ff7da.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
1. just run chmsee on any chm
2.
3.

Actual results:
Error

Expected results:
No error, view chm

Additional info:
Upgrading to chmsee-2.0.2-18.gitd40ff7da.fc22.x86_64
http://koji.fedoraproject.org/koji/buildinfo?buildID=630726
fixes this. It is also apparent in the log:

* Fri Apr 24 2015 Yijun Yuan <bbbush.yuan@gmail.com> - 2.0.2-18.gitd40ff7da - rebuild for xulrunner 37

But for some reason this has not been pushed to update yet.

Comment 1 Hin-Tak Leung 2015-08-15 23:00:13 UTC
got broken again!

$ rpm -q xulrunner
xulrunner-38.0-1.fc22.x86_64


$ chmsee

(process:26564): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '38.0' is not compatible with
minVersion >= 22.0
maxVersion <= 37.*
$ rpm -q chmsee
chmsee-2.0.2-18.gitd40ff7da.fc22.x86_64

https://bugzilla.redhat.com/show_bug.cgi?id=1228358#c1
suggests changing /usr/lib/chmsee/application.ini to * from 37.*

Comment 2 Fedora Update System 2015-08-16 04:54:54 UTC
chmsee-2.0.2-21.gitd40ff7da.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/chmsee-2.0.2-21.gitd40ff7da.fc23

Comment 3 Fedora Update System 2015-08-16 04:55:01 UTC
chmsee-2.0.2-19.gitd40ff7da.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/chmsee-2.0.2-19.gitd40ff7da.fc22

Comment 4 Fedora Update System 2015-08-16 04:55:10 UTC
chmsee-2.0.2-19.gitd40ff7da.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/chmsee-2.0.2-19.gitd40ff7da.fc21

Comment 5 Fedora Update System 2015-08-18 05:13:20 UTC
Package chmsee-2.0.2-21.gitd40ff7da.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing chmsee-2.0.2-21.gitd40ff7da.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13536/chmsee-2.0.2-21.gitd40ff7da.fc23
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-08-19 08:12:12 UTC
chmsee-2.0.2-19.gitd40ff7da.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-08-26 04:33:46 UTC
chmsee-2.0.2-21.gitd40ff7da.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-08-26 16:49:37 UTC
chmsee-2.0.2-19.gitd40ff7da.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Hin-Tak Leung 2015-10-26 04:39:30 UTC
Is broken again!!!!

$ rpm -q chmsee
chmsee-2.0.2-21.gitd40ff7da.fc23.x86_64

$ rpm -q xulrunner
xulrunner-40.0-1.fc23.x86_64

in /usr/lib64/chmsee/application.ini:

[Gecko]
MinVersion=22.0
MaxVersion=39.*

Comment 10 Hin-Tak Leung 2015-10-26 04:41:45 UTC
Could we change that MaxVersion=x.* to * permanently to stop it breaking again?

Comment 11 LiZhenbo 2015-12-03 03:18:00 UTC
(In reply to Hin-Tak Leung from comment #10)
> Could we change that MaxVersion=x.* to * permanently to stop it breaking
> again?

What if the API of Gecko really changed, and caused other bugs?
Seems that chmsee needs to be rebuilt very frequently

Comment 12 Yijun Yuan 2016-02-14 04:12:38 UTC
Sorry I cannot keep up with this anymore.

Comment 13 Yijun Yuan 2016-02-14 04:19:51 UTC
*** Bug 1228358 has been marked as a duplicate of this bug. ***

Comment 14 Hin-Tak Leung 2016-04-10 22:30:13 UTC
Yes, it has completely broken due to API change as of now:

$ rpm -q xulrunner
xulrunner-44.0-1.fc23.x86_64

The 39->40 was okay, but I have not noticed since 40.

Recently found that it is completely broken. Unfortunately mono uses it by default to emulate .net's chm viewing... I'll file a separate bug about it being completely broken.


Note You need to log in before you can comment on or make changes to this bug.