Bug 12284 - anaconda silently dies on a missing floppy
anaconda silently dies on a missing floppy
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
: 12420 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-14 17:44 EDT by Michal Jaegermann
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-13 17:02:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2000-06-14 17:44:05 EDT
In GUI installer for beta1 release I provoked an error in a boot
floppy creation by simply choosing to do that and _not_ putting a
floppy in a drive (but this could be a bad floppy or an honest
mistake).  Anaconda prompty died and it stopped to react on any
keyboard or mouse input.  After switching to text consoles and back a
screen image was also not updated (a general outline was still present
on a monitor).  No traceback, no messages, no recorded errors; just a
silent death. I was able to finish an installation "manually", from a
command line, but for a newbie all work up to this point would be
lost.

  Michal
  michal@harddata.com
Comment 1 Michael Fulbright 2000-06-14 17:54:19 EDT
Please verify in test lab.
Comment 2 Brock Organ 2000-06-27 13:07:48 EDT
hmmm ... I could not verify this using beta1 or beta2 ...

Are you getting this behavior in beta2 ...? Any error messages on the VCs ...?
Comment 3 Brock Organ 2000-06-27 14:40:48 EDT
*** Bug 12420 has been marked as a duplicate of this bug. ***
Comment 4 Erik Troan 2000-07-13 17:02:04 EDT
I'm closing this as we can't reproduce it. *Please* try again w/ beta 3, and
repoen this bug if
it's still happening. Every time we try this, it works properly <sigh>.
Comment 5 giulioo 2000-12-06 06:05:02 EST
I tested on rh70. GUI.
I put a floppy in, but it seems it had some bad sectors so that vt4 was full of 
i/o errors.  anaconda went on for a lot of time this way, frozen. 
Then it said "there is a problem on the boot disk...", I took out the disk and 
clicked "go on", thinking it would skip the boot disk, but it tried again (I 
didn't check "skip..") and this time there was no boot disk in the floppy 
drive. anaconda didn't understand this and tried hard to create the boot disk 
(vt4 full of i/o errors), I had to wait for about 10 minutes before anaconda 
gave up, then I chose to skip the boot disk phase and I could complete the 
install succesfully.
I think you should do a quick test to see if the floppy is actually in.

Note You need to log in before you can comment on or make changes to this bug.