Bug 12420 - anaconda lockup after boot disk was created.
anaconda lockup after boot disk was created.
Status: CLOSED DUPLICATE of bug 12284
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-18 13:23 EDT by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 14:40:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autopsy of a locked up anaconda. (3.77 KB, text/plain)
2000-06-18 13:25 EDT, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2000-06-18 13:23:53 EDT
Graphical install.

Got as far as "creating a boot disk".  Told it to create a boot disk.  The
floppy grumbled for a while, then anaconda froze up.

Went to a terminal window on ctrl-alt-f3.  The hard disk, with the
installed system, was mounted.  I am attaching the output of ps + strace
analysis of the anaconda processes (there was a setxkbmap zombie process
too).

I've reproduced this twice.  This was a stock server install, but NFS
server was unchecked, and I told anaconda to wipe and partition the 9 GB
disk by itself.
Comment 1 Sam Varshavchik 2000-06-18 13:25:09 EDT
Created attachment 543 [details]
autopsy of a locked up anaconda.
Comment 2 Brock Organ 2000-06-19 18:26:33 EDT
hmm ... I am having trouble reproducing this behavior ...

does this occur for all occurences of boot disk creation (TUI and GUI) ...?
does this occur regardless of install type (custom, server, etc.) ...?
does this occur over multiple disks (ie no bad disk) ...?
Comment 3 Sam Varshavchik 2000-06-19 18:32:51 EDT
textmode install is fine.

i've only tried twice to do a server install, happened every time.  will have to
try some other types of installs.

the attached ps dump shows setxkbmap zombie process.  things must be crashing
some time after setxkbmap is executed to do whatever it's supposed to do, but
before the parent process has a chance to reap it.

Comment 4 Brock Organ 2000-06-27 14:40:50 EDT

*** This bug has been marked as a duplicate of 12284 ***

Note You need to log in before you can comment on or make changes to this bug.