Bug 122869 - xinput script not run, needs to be renamed to xinput.sh
xinput script not run, needs to be renamed to xinput.sh
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
2
All Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
: i18n
: 125205 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-05-09 13:14 EDT by isaac
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version: 3.42-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-13 08:18:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description isaac 2004-05-09 13:14:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506

Description of problem:
It was found that in script /etc/X11/xinitrc/xinitrc, it will only
execute   those scripts with extension as ".sh". 

However, the two scripts (xinput and xmbind) come with the package
doesn't renamed to the correct extension.

Version-Release number of selected component (if applicable):
xinitrc-3.40-1

How reproducible:
Always

Steps to Reproduce:
1. Choose A language other than English
2. Choose KDE Desktop
3. Login
    

Additional info:
Comment 1 Warren Togami 2004-05-10 03:26:31 EDT
Ack!  This change made on Saturday May 8th breaks CJK support for both
XIM and IIIMF methods.  It would be VERY embarassing to release FC2
with this problem.  I am making and testing a potential update, so
mharris can approve it quickly when he wakes up.
Comment 2 Jens Petersen 2004-05-10 04:57:26 EDT
Index: xinitrc.spec
===================================================================
RCS file: /cvs/devel/xinitrc/xinitrc.spec,v
retrieving revision 1.66
diff -u -r1.66 xinitrc.spec
--- xinitrc.spec	7 May 2004 14:22:01 -0000	1.66
+++ xinitrc.spec	10 May 2004 08:32:12 -0000
@@ -38,6 +38,7 @@
 %install
 rm -rf $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install
+mv $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/xinput{,.sh}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
Comment 3 Warren Togami 2004-05-12 14:16:59 EDT
Please downgrade to xinitrc-3.39-1 which works fine.  xinitrc-3.40-1
was reverted from the tree because it would require too many other
packages to be changed.  Well... two... but they didn't want to risk it.
Comment 5 Mike A. Harris 2004-06-02 03:02:14 EDT
Ok, me and Jens chatted about this in IRC today and we seem to have
come to a rough decision how to proceed for this issue.

We both believe that having the xinitrc.d directory only process
*.sh scripts is a good idea, much for the same reason it is a good
idea for other directories throughout the system of the form
"foo.d" do the same thing.  It prevents random files from being
executed or sourced accidentally, and it is all to possible that
any variety of backup files may exist, including ones with
unpredictable names.

The question then is how we should proceed to make the change.  We
know of 2 scripts in Fedora Core 2 that break with this change
currently, one of which is in the openmotif package.

If we were to fix xinput to xinput.sh, and to fix the openmotif
package, then we'd need to issue erratum for all 3 packages for FC2,
which is definitely doable.

There may however be other lurking issues that we have not forseen
and which may come back to haunt us a few days/weeks/months later,
such as a 3rd party package plopping a script in the dir that does
not end in .sh, causing it to break.  Jens and I both believe that
it would be very bad to have an erratum update break something
in a stable cycle in this manner.

The other alternative we have is to push an updated package into
updates-testing, which would shield things a bit for a while until
we find out if anything breaks.  In order to get a reasonable
guarantee however, we'd be best to leave it in testing for a few
weeks, and if we do that, we might as well just do it in rawhide
instead, where we /can/ break things in a reasonable manner.

It may be useful to get feedback from fedora-devel-list also
perhaps.
Comment 6 petrosyan 2004-06-02 08:22:59 EDT
tpb package from fedora.us creates /etc/X11/xinit/xinitrc.d/tpb file,
which would stop working after those changes.
Comment 7 Jens Petersen 2004-06-02 13:01:38 EDT
Anl, can't the tpb script be renamed to tpb.sh?

Mike, you still haven't renamed xinput.sh in xinitrc-3.41. :-/
Comment 8 Ville Skyttä 2004-06-02 14:26:56 EDT
The latest incarnation of tpb in the fedora.us QA queue has been
"fixed" wrt this, thanks to Ani for the heads up.
https://bugzilla.fedora.us/show_bug.cgi?id=1227

(I think it's a good idea to limit xinitrc.d processing to *.sh only.)
Comment 9 Jens Petersen 2004-06-16 05:04:00 EDT
Ville, that is nice to hear!  However xinitrc and openmotif
still haven't been fixed!! :-(
Comment 10 Jens Petersen 2004-06-16 05:22:48 EDT
Changing product version to 2 since xinitrc-3.41 went into fc2-updates.
Comment 11 Jens Petersen 2004-06-16 05:23:54 EDT
*** Bug 125205 has been marked as a duplicate of this bug. ***
Comment 12 Jens Petersen 2004-06-21 08:52:13 EDT
openmotif has been fixed: so that just leaves xinput...
Comment 13 Jens Petersen 2004-07-13 08:17:17 EDT
Sorry, the fix for FC2 was in 3.42-1: 4.0.1-1 is for FC-devel.

Note You need to log in before you can comment on or make changes to this bug.