Bug 125205 - xinitrc can't execute /etc/X11/xinit/xinirc.d/xinput
xinitrc can't execute /etc/X11/xinit/xinirc.d/xinput
Status: CLOSED DUPLICATE of bug 122869
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Depends On:
  Show dependency treegraph
Reported: 2004-06-03 12:04 EDT by SEKINE Tatsuo
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-02 02:26:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description SEKINE Tatsuo 2004-06-03 12:04:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
From ver. 3.40-1, /etc/X11/xinit/xinitrc script source only
/etc/X11/xinitr.d/*.sh scripts.
But all files located in /etc/X11/xinit/xinitrc.d/ are not named "*.sh".

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. ls /etc/X11/xinit/xinitrc.d/

Actual Results:  xinput  xmbind

Expected Results:  xinput.sh  xmbind.sh

Additional info:

On my machine:
  $ rpm -qf /etc/X11/xinit/xinitrc.d/*

I do not install full package, thus I don't know whether there are no
other package influenced by this problem.
Comment 1 Radu Cornea 2004-06-03 14:38:58 EDT
The latest update of xinitrc broke my xinit scripts too. None of the
scripts in xinitrc.d have a .sh extension, what was the reason for
changing xinitrc to only run the .sh files?

From /etc/X11/xinit/xinitrc:

# run all system xinitrc shell scripts.
for file in /etc/X11/xinit/xinitrc.d/* ; do
    if echo $file | grep -q "\.sh$" ; then
        . $file
        echo "warning: $file does not end in .sh extension, ignoring"
Comment 2 khirano 2004-06-06 08:46:32 EDT
Add myself (khirano) to CC.  Thanks.
Comment 3 SEKINE Tatsuo 2004-06-06 22:34:39 EDT
Probably /etc/X11/xinit/xinitrc is not used on GDM(/gnome-session) 
In that case, /etc/X11/xdm/Xsession file is used for startup session.

Either way, what should be fixed is file names 
under /etc/X11/xinit/xinitrc.d/.

BTW, if file "xiput" is not sourced, most of CJK users couldn't  
input any his/her native language characters.

It means that CJK users can do nothing on FC2 desktop system now :-<
I change severity to "HIGH" and add keyword "i18n".
Comment 4 Need Real Name 2004-06-16 04:44:45 EDT
I guess that the reason for only sourcing *.sh files
was to avoid executing files like xinput.rpmnew or
xinput.rpmorig ;-)
Comment 5 Jens Petersen 2004-06-16 05:23:50 EDT

*** This bug has been marked as a duplicate of 122869 ***

Note You need to log in before you can comment on or make changes to this bug.