Bug 1229046 - mark group as installed only after successful transaction
Summary: mark group as installed only after successful transaction
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1244179 1251813 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-07 20:21 UTC by Bruno Wolff III
Modified: 2016-01-04 19:53 UTC (History)
13 users (show)

Fixed In Version: dnf-1.1.5-1.fc23 dnf-1.1.5-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 21:59:49 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruno Wolff III 2015-06-07 20:21:22 UTC
Description of problem:
While doing some group installs I hit some file conflicts. Even though know packages were installed in either case, dnf treated both groups as fully installed and I needed to use group mark remove in order to try installing them again.

Comment 1 Honza Silhan 2015-07-24 12:01:43 UTC
Michal, isn't it fixed in the upstream? The problem is that the group is marked as installed before the transaction successfully finishes.

Comment 2 Radek Holy 2015-07-29 15:11:38 UTC
*** Bug 1244179 has been marked as a duplicate of this bug. ***

Comment 3 Michal Luscon 2015-07-31 07:51:02 UTC
Hi Bruno,

could you please describe your problem in more detail or confirm that this is really a duplicate of #1244179?

Comment 4 Morris Jones 2015-08-06 18:52:08 UTC
The bug may be more than just out of space as in #1244179. It occurs when there is a packaging error in a group.

The bug appears attempting to group install 'Electronic Lab'. The group has conflicting packages, (most likely a qucs packaging error) and fails to install. with the following message:

Error: Transaction check error:
  file /usr/bin/admsXml conflicts between attempted installs of mot-adms-2.3.2-3.fc22.x86_64 and qucs-0.0.18-2.fc22.x86_64

After that, the system thinks the group is installed: 

sudo dnf group install 'Electronic Lab'
Last metadata expiration check performed 0:01:16 ago on Thu Aug  6 11:26:48 2015.
Group 'Electronic Lab' is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

No packages were installed:

sudo dnf remove mot-adms
No match for argument: mot-adms
Error: No packages marked for removal.

It can be cleared with:

sudo dnf group mark remove 'Electronic Lab'
Last metadata expiration check performed 0:10:48 ago on Thu Aug  6 11:26:48 2015.
Groups marked removed: Electronic Lab

Comment 5 Michal Luscon 2015-08-11 14:37:24 UTC
*** Bug 1251813 has been marked as a duplicate of this bug. ***

Comment 6 Samuel Sieb 2015-09-25 20:42:06 UTC
Is there a dnf equivalent to "yum shell" or some other way to install a group without a particular package?

Comment 7 Michal Luscon 2015-11-23 15:40:21 UTC
Yes, you can exclude packages by -x option.

Comment 8 Fedora Update System 2015-12-18 17:47:25 UTC
dnf-plugins-core-0.1.15-1.fc23 dnf-1.1.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0

Comment 9 Fedora Update System 2015-12-18 17:48:58 UTC
dnf-plugins-core-0.1.15-1.fc22 dnf-1.1.5-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6

Comment 10 Fedora Update System 2015-12-19 19:59:49 UTC
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf dnf-plugins-core'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0

Comment 11 Fedora Update System 2015-12-22 15:35:30 UTC
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6

Comment 12 Fedora Update System 2015-12-22 21:59:03 UTC
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-01-04 19:52:22 UTC
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.