Bug 1244179 - Can't continue installation of group after installation of that group failed on missing space
Summary: Can't continue installation of group after installation of that group failed ...
Keywords:
Status: CLOSED DUPLICATE of bug 1229046
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-17 12:08 UTC by Jiri Konecny
Modified: 2015-07-29 15:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-29 15:11:38 UTC
Type: Bug


Attachments (Terms of Use)
installation-screenshot (42.10 KB, image/png)
2015-07-17 12:08 UTC, Jiri Konecny
no flags Details

Description Jiri Konecny 2015-07-17 12:08:42 UTC
Created attachment 1053051 [details]
installation-screenshot

Description of problem:
When 'dnf group install "group name"' fails on missing space when installing (not downloading) of packages. The next installation of this group will give message "is already installed, skipping"

Version-Release number of selected component (if applicable):
1.0.1

How reproducible:
Always

Steps to Reproduce:
1. Reduce the free space on the '/' (in my case 1.1G, you can use fallocate for this)
2. Start installation of group (my case dnf group install "Fedora Workstation")
3. You get an error "more space is needed"
4. Start the second installation of group (dnf group install "Fedora Workstation")

Actual results:
Group is already installed.

Expected results:
Install the missing packages or install whole group again.

Comment 1 Jiri Konecny 2015-07-17 12:13:55 UTC
When I use command 
'dnf group upgrade "Fedora Workstation"'
I get message: "ERROR: Group 'Fedora Workstation' is not installed."

Comment 2 Sylvain Pasche 2015-07-18 21:21:03 UTC
I encountered the same issue.

I used the following command to let dnf think the group isn't installed so it can be installed again:
dnf group mark remove "Fedora Workstation"

Comment 3 Jiri Konecny 2015-07-20 06:32:07 UTC
Yeah I found that too later.
Thank you for giving this here. I forgot to do that.

Comment 4 Radek Holy 2015-07-29 15:11:38 UTC

*** This bug has been marked as a duplicate of bug 1229046 ***


Note You need to log in before you can comment on or make changes to this bug.