Bug 123045 - subversion-perl: bad RPATHs, other enhancements
Summary: subversion-perl: bad RPATHs, other enhancements
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-11 19:24 UTC by Ville Skyttä
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 1.0.2-2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 19:12:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Clean/fix up subversion-perl installation and dependencies (2.02 KB, patch)
2004-05-11 19:25 UTC, Ville Skyttä
no flags Details | Diff
Avoid RPATHs with older perls, add missing ldconfigs (545 bytes, patch)
2004-05-16 14:44 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2004-05-11 19:24:43 UTC
check-rpaths from fedora-rpmdevtools (www.fedora.us) yells with
1.0.2-1 about build root traces in -perl RPATHs:

File
'/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi/auto/SVN/_Core/_Core.so'
contains an invalid rpath
'/home/scop/rpmbuild/BUILD/subversion-1.0.2/subversion/libsvn_client/.libs'
[...]
File
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi/auto/SVN/_Client/_Client.so'
contains an invalid rpath
'/home/scop/rpmbuild/BUILD/subversion-1.0.2/subversion/libsvn_client/.libs'
[...]

Other notes when rebuilding this on FC1:
- checking for makeinfo... echo cannot run makeinfo
--> BuildRequires: texinfo?

Will also attach a suggested specfile patch for cleaning up the -perl
installation wrt. directory ownership bloat and requiring the proper
perl(:MODULE_COMPAT_*) dirs.

Comment 1 Ville Skyttä 2004-05-11 19:25:58 UTC
Created attachment 100161 [details]
Clean/fix up subversion-perl installation and dependencies

Comment 2 Joe Orton 2004-05-11 20:06:56 UTC
1. MODULE_COMPAT_* I've already added...
2. RPATH: check the real 1.0.2-1 binaries, it was a perl bug
2. makeinfo: yes, though it isn't actually used during the build at all
3. installation dirs: thanks for the patch!


Comment 3 Ville Skyttä 2004-05-11 20:39:34 UTC
Thanks for the quick status update.

Ideas how to work around the RPATH issue with FC1 perl?  Copy a
patched MM_Unix.pm to $RPM_BUILD_ROOT, set $PERL5LIB so that it points
to it... ugh :/  https://bugzilla.fedora.us/show_bug.cgi?id=1576

By the way, comment 2 triggers a tiny Bugzilla bug; a spurious "bug 2"
link between the 2nd and 3rd lines :)

Comment 4 Joe Orton 2004-05-11 20:45:41 UTC
No idea, might be easiest to get Chip to fix the FC1 perl too, if it
was the one-liner MM_Unix.pm patch? bug 3 is more interesting than bug
2, I notice.  I've put your patch into CVS, it will go out as an FC2
update when a new 1.0.x is release is out upstream; leaving this open
til then.

Comment 5 Ville Skyttä 2004-05-16 14:44:48 UTC
Created attachment 100256 [details]
Avoid RPATHs with older perls, add missing ldconfigs

This patch avoids RPATHs when rebuilt with older perl package versions such as
the FC1 one, and adds missing ldconfigs for the -perl subpackage.

Comment 6 Joe Orton 2004-05-16 15:22:43 UTC
"LD_RUN_PATH=" presumably still leaves an RPATH of the empty string in
the binaries with the broken MM_Unix.pm?  That's still wrong.

Thanks for the ldconfig's, I'll put those in.


Comment 7 Ville Skyttä 2004-05-16 15:37:25 UTC
You're right, the empty RPATH is still there.  Dammit...

Comment 8 Joe Orton 2004-05-19 19:12:50 UTC
MODULE_COMPAT_* and the man pages are fixed in the -1.0.2-2.1 update
for FC2. Looks like there'll be a 1.0.3 update sometime this week, so
the ldconfig's will come in that update.  Thanks for the patches!

Comment 9 Ville Skyttä 2004-05-19 19:21:13 UTC
Cool.  And FYI: here's one working but dirty hack that avoids empty
RPATHs in perl packages for pre-FC2 perls:
https://bugzilla.fedora.us/attachment.cgi?id=670&action=view


Note You need to log in before you can comment on or make changes to this bug.