Bug 1231054 - Exception when clicking "more activity" when there is no valid "editor url"
Exception when clicking "more activity" when there is no valid "editor url"
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.7
Unspecified Unspecified
high Severity medium
: ---
: 3.7
Assigned To: Alex Eng
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-12 02:06 EDT by Damian Jansen
Modified: 2015-07-21 22:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.7.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3844)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-21 22:19:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2015-06-12 02:06:19 EDT
Description of problem:
If the user clicks "more activity" on the dashboard enough to reach some condition of their activity, it results in an exception.
It's unsure if this is related to having a deleted project, deleted version, or simply the end of the recorded activity.

Version-Release number of selected component (if applicable):
3.7-snapshot

How reproducible:
"Not sure", always

Steps to Reproduce:
Pre: in the test environment, there was three pages of activity, including some deleted projects and versions
1. Log in
2. At the dashboard, click more activity repeatedly

Actual results:
The loader keeps loading.

java.lang.NullPointerException
at org.zanata.action.ActivityAction.getEditorUrl(ActivityAction.java:205) [classes:]
at org.zanata.action.ActivityAction.getActivityMessage(ActivityAction.java:117) [classes:]

Expected results:
End / unavailable activity

Additional info:
Comment 1 Alex Eng 2015-06-12 14:21:39 EDT
Issue should be fixed as part of https://bugzilla.redhat.com/show_bug.cgi?id=1229940. 

Can you please verify if the issue is still occurring?
Comment 2 Damian Jansen 2015-06-17 22:11:01 EDT
Verified still occurring in release branch.
Comment 3 Alex Eng 2015-06-18 01:59:47 EDT
Pull request:

https://github.com/zanata/zanata-server/pull/880
Comment 4 Damian Jansen 2015-06-22 23:09:28 EDT
Verified at 2ff4212f0b01812bc034937e8a6094fd4d3a446e

Note You need to log in before you can comment on or make changes to this bug.