Bug 1231359 - [RFE] Exposed ports support
Summary: [RFE] Exposed ports support
Keywords:
Status: CLOSED DUPLICATE of bug 1231362
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-12 19:34 UTC by Partha Aji
Modified: 2017-02-23 19:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-19 19:12:19 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 7864 0 None None None 2016-04-22 15:41:13 UTC

Description Partha Aji 2015-06-12 19:34:24 UTC
The configuration or environment part of the wizard should show a way of adding exposed ports. The Docker Remote API supports it but Fog doesn't yet. Assume Fog does support it as I have a patch pending review.
The format for exposed ports goes like
<pre>
 { "ExposedPorts" : [ "22/tcp": {}, "80/tcp": {}] } 
</pre>

Yes, key is the port/protocol, value is.. nothing?

Comment 1 Partha Aji 2015-06-12 19:34:24 UTC
Created from redmine issue http://projects.theforeman.org/issues/7864

Comment 3 Bryan Kearney 2015-06-15 14:39:56 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7864 has been closed
-------------
Vanya Jauhal
Applied in changeset commit:foreman-docker|8e2848d58b12a71a89f19e6eb98be790d5f19067.

Comment 4 Bryan Kearney 2015-06-19 19:12:19 UTC

*** This bug has been marked as a duplicate of bug 1231362 ***


Note You need to log in before you can comment on or make changes to this bug.