Bug 1231362 - [RFE] Exposed ports support
Summary: [RFE] Exposed ports support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1231359 1231360 1231361 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-12 19:39 UTC by Partha Aji
Modified: 2019-09-26 14:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:16:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 7864 None None None 2016-04-22 15:38:56 UTC

Description Partha Aji 2015-06-12 19:39:09 UTC
The configuration or environment part of the wizard should show a way of adding exposed ports. The Docker Remote API supports it but Fog doesn't yet. Assume Fog does support it as I have a patch pending review.
The format for exposed ports goes like
<pre>
 { "ExposedPorts" : [ "22/tcp": {}, "80/tcp": {}] } 
</pre>

Yes, key is the port/protocol, value is.. nothing?

Comment 1 Partha Aji 2015-06-12 19:39:10 UTC
Created from redmine issue http://projects.theforeman.org/issues/7864

Comment 3 Bryan Kearney 2015-06-15 14:40:00 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7864 has been closed
-------------
Vanya Jauhal
Applied in changeset commit:foreman-docker|8e2848d58b12a71a89f19e6eb98be790d5f19067.

Comment 4 Bryan Kearney 2015-06-19 19:12:08 UTC
*** Bug 1231361 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2015-06-19 19:12:12 UTC
*** Bug 1231360 has been marked as a duplicate of this bug. ***

Comment 6 Bryan Kearney 2015-06-19 19:12:20 UTC
*** Bug 1231359 has been marked as a duplicate of this bug. ***

Comment 7 Tazim Kolhar 2015-11-16 13:00:35 UTC
Hi,

please provide verification steps

thanks in advance

Thanks and Regards,
Tazim

Comment 11 Lukas Pramuk 2016-05-11 16:08:14 UTC
VERIFIED.

@Sat6.2.0-Beta
tfm-rubygem-foreman_docker-2.0.1.4-1.el7sat.noarch

1) Start creating a container, into Command enter "python -m SimpleHTTPServer 12345" and Add Exposed Port 12345/tcp

2) Run the container and check its IP address

3) Check the container info at host
@docker_host # docker ps
CONTAINER ID        IMAGE                                           COMMAND                  CREATED             STATUS              PORTS                NAMES
651f1720780c        <registry>:443/rhel6.8:latest   "python -m SimpleHTTP"   About an hour ago   Up About an hour    123/udp, 12345/tcp   rhel68_python

3) Connect to the exposed port
@docker_host # nc <IP address> 12345
GET /

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2 Final//EN"><html>
...

4) Check UI Logs tab for a connection record
          Serving HTTP on 0.0.0.0 port 12345 ...
172.17.0.1 - - [11/May/2016 07:55:15] "GET /" 200 -


+ I tested the same with UDP port
+ I tested that wrong values for port number are handled correctly

Comment 13 errata-xmlrpc 2016-07-27 09:16:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.