Bug 1231379 - Do not pull vdsm-reg onto node
Summary: Do not pull vdsm-reg onto node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 994451 (view as bug list)
Depends On: 1204793 1231836
Blocks: 515681 629392 753315 994451 1097685 1113622 1115118
TreeView+ depends on / blocked
 
Reported: 2015-06-12 21:41 UTC by Dan Kenigsberg
Modified: 2016-03-09 14:30 UTC (History)
17 users (show)

Fixed In Version: ovirt-node-plugin-vdsm-0.6.1-1.el7ev
Doc Type: Bug Fix
Doc Text:
The 'vdsm-reg' tool has been deprecated and replaced with 'vdsm-tool register' to register supported distributions with Red Hat Enterprise Virtualization.
Clone Of: 1204793
Environment:
Last Closed: 2016-03-09 14:30:12 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1231799 low CLOSED [RFE] hosted-engine-setup should let its user choose the name of the bridge to be created (and have ovirtmgmt as default... 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 42304 master MERGED spec: Do not pull vdsm-reg Never
oVirt gerrit 43254 master MERGED vdsm-reg: remove the sub-project Never

Internal Links: 1231799

Description Dan Kenigsberg 2015-06-12 21:41:09 UTC
Ancient Engines (before http://www.ovirt.org/Features/Normalized_ovirtmgmt_Initialization ) expected to find a "rhevm" bridge ("ovirtmgmt" upstream) when adding a new host.

Now that we no longer support engine < 3.4, vdsm-reg does not need to create the bridge.

The simplest way to avoid the bridge's creation by vdsm-reg is to drop vdsm-reg from the node. If I am mistaken, and it is ovirt-node component that pulls vdsm-reg, please move this bug there. If I am even more mistaken, and there's any need to keep vdsm-reg on the node, move this bug to vdsm, where we'd disable the bridge creation.

Comment 1 Yaniv Lavi 2015-06-21 15:49:49 UTC
Should this be MODIFIED?

Comment 2 Douglas Schilling Landgraf 2015-06-21 15:51:49 UTC
(In reply to Yaniv Dary from comment #1)
> Should this be MODIFIED?

Yes, thanks!

Comment 3 Douglas Schilling Landgraf 2015-06-24 18:41:01 UTC
*** Bug 1135921 has been marked as a duplicate of this bug. ***

Comment 4 Douglas Schilling Landgraf 2015-06-24 18:42:58 UTC
*** Bug 994451 has been marked as a duplicate of this bug. ***

Comment 6 Chaofeng Wu 2015-10-08 09:02:42 UTC
Verified on rhev-hypervisor7-7.2-20150928.0.iso.

Test steps:
1. Install rhev-hypervisor7-7.2-20150928.0.iso.
2. Login to RHEV-H, run the command: 
   # rpm -qa | grep vdsm-reg

Result:
After step2,  nothing output.

This bugs has been fixed, changed the status to VERIFIED.

Comment 8 errata-xmlrpc 2016-03-09 14:30:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.