Bug 12314 - RPM 3 does not upgrade to RPM 4
RPM 3 does not upgrade to RPM 4
Status: CLOSED DUPLICATE of bug 12401
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-16 02:39 EDT by patola
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-16 02:39:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description patola 2000-06-16 02:39:36 EDT
It will be clearer if I show the command lines:

[patola@sheilamello rpm]$ ls -la
total 5141
drwxr-xr-x   2 root     root         1024 Jun 16 02:30 .
drwxrwxrwx  14 root     root         2048 Jun 16 03:40 ..
-rw-r--r--   1 root     root      1948684 Jun 16 02:18
rpm-4.0-0.33.i386.rpm
-rw-r--r--   1 root     root      1722979 Jun 16 02:05 rpm-4.0-0.33.src.rpm
-rw-r--r--   1 root     root        59803 Jun 16 02:18
rpm-build-4.0-0.33.i386.r
pm
-rw-r--r--   1 root     root      1474275 Jun 16 02:22
rpm-devel-4.0-0.33.i386.r
pm
-rw-r--r--   1 root     root        25902 Jun 16 02:22
rpm-python-4.0-0.33.i386.
rpm
[patola@sheilamello rpm]$ rpm -Uvv rpm*
D: counting packages to install
D: found 5 packages
D: looking for packages to download
D: retrieved 0 packages
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-4.0-0.33.i386.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-4.0-0.33.src.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-build-4.0-0.33.i386.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-devel-4.0-0.33.i386.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-python-4.0-0.33.i386.rpm cannot be installed
D: found 0 source and 0 binary packages
[patola@sheilamello rpm]$ 

	You see, it looks like there's just no way to upgrade from rpm 3
to rpm 4. rpm 3 does not recognize the rpm 4 format and so I can't upgrade.
And that's all. Any solution?

	Patola
Comment 1 Jeff Johnson 2000-06-20 21:53:53 EDT

*** This bug has been marked as a duplicate of 12401 ***

Note You need to log in before you can comment on or make changes to this bug.