Bug 12401 - RPM 3 cannot upgrade to RPM 4
Summary: RPM 3 cannot upgrade to RPM 4
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 12308 12314 12330 13098 13446 13656 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-17 23:07 UTC by patola
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-20 15:59:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description patola 2000-06-17 23:07:22 UTC
I want to get some rpm files from the rawhide distribution.
	Problem is, they all use RPM 4 format. And I have RPM 3.04.
	That would not be a problem, I've thought. I can upgrade.
	But I can't: since the RPM 4 rpm is in RPM 4 format, RPM 3
	cannot use it to upgrade itself.

	That's the command-line I've tried:
[root@sheilamello rpm]# ls -la
total 5141
drwxr-xr-x   2 root     root         1024 Jun 16 02:30 .
drwxrwxrwx  15 root     root         2048 Jun 17 17:43 ..
-rw-r--r--   1 root     root      1948684 Jun 16 02:18
rpm-4.0-0.33.i386.rpm
-rw-r--r--   1 root     root      1722979 Jun 16 02:05 rpm-4.0-0.33.src.rpm
-rw-r--r--   1 root     root        59803 Jun 16 02:18
rpm-build-4.0-0.33.i386.rpm
-rw-r--r--   1 root     root      1474275 Jun 16 02:22
rpm-devel-4.0-0.33.i386.rpm
-rw-r--r--   1 root     root        25902 Jun 16 02:22
rpm-python-4.0-0.33.i386.rpm                       

[root@sheilamello rpm]# rpm -Uvv *
D: counting packages to install
D: found 5 packages
D: looking for packages to download
D: retrieved 0 packages
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-4.0-0.33.i386.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-4.0-0.33.src.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-build-4.0-0.33.i386.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-devel-4.0-0.33.i386.rpm cannot be installed
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-python-4.0-0.33.i386.rpm cannot be installed
D: found 0 source and 0 binary packages
[root@sheilamello rpm]#

Comment 1 Hardy Mayer 2000-06-20 15:59:35 UTC
Same problem with several other packages;  e.g, 
gimp-1.1.23-3.i386.rpm :

rpm -vv -Uvh gimp-1.1.23-3.i386.rpm 
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: retrieved 0 packages
only packages with major numbers <= 3 are supported by this version of RPM
error: gimp-1.1.23-3.i386.rpm cannot be installed
D: found 0 source and 0 binary packages




Comment 2 Jeff Johnson 2000-06-21 01:51:40 UTC
I've just put a test version of rpm-3.0.5 in
	ftp://ftp.rpm.org/pub/rpm/test
that will read version 4 packages. Release of rpm-3.0.5 will be Real Soon Now.

Comment 3 Jeff Johnson 2000-06-21 01:53:21 UTC
*** Bug 12330 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Johnson 2000-06-21 01:53:52 UTC
*** Bug 12314 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Johnson 2000-06-21 01:54:21 UTC
*** Bug 12308 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Johnson 2000-07-10 19:44:27 UTC
*** Bug 13446 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Johnson 2000-07-10 20:06:44 UTC
*** Bug 13098 has been marked as a duplicate of this bug. ***

Comment 8 Jeff Johnson 2000-07-10 22:47:33 UTC
*** Bug 13656 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.