Bug 123141 - SMTP Auth no longer working after RHEL 3 Update 2
SMTP Auth no longer working after RHEL 3 Update 2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Thomas Woerner
:
: 123173 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 18:19 EDT by Pete Deffendol
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-18 15:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Deffendol 2004-05-12 18:19:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I updated to Taroon Update 2 using up2date.  Afterwards, SMTP plain
authentication was no longer working.  In order to get it working, I
had to copy the file /etc/pam.d/smtp.sendmail to /etc/pam.d/smtp and
restart sendmail and saslauthd services.

FYI, I do not have Postfix installed on the system.

Version-Release number of selected component (if applicable):
sendmail-8.12.11-3, cyrus-sasl-2.1.15-8

How reproducible:
Didn't try

Steps to Reproduce:
1. Update to Taroon Update 2
2. Try to send mail using SMTP Plain authentication
3. Client keeps popping up password box
4. Cancellation results in "did not issue MAIL/EXPN/VRFY/ETRN during
connection to MTA" in /var/log/maillog
5. cp /etc/pam.d/smtp.sendmail /etc/pam.d/smtp and restart sendmail
and saslauthd to solve the problem.
    

Actual Results:  SMTP auth works as expected.

Additional info:
Comment 1 Steve Bonneville 2004-05-13 12:17:34 EDT
It looks like these symlinks are not getting set on upgrade to
sendmail-8.12.11-3 from pre-RHEL 3 Update 2 sendmail:

/etc/pam.d/smtp -> /etc/alternatives/mta-pam
/etc/alternatives/mta-pam -> /etc/pam.d/smtp.sendmail

Alternatives seems to know about them, though, and redhat-switch-mail
or 'alternatives --config mta' do set them correctly if run.
Comment 2 Thomas Woerner 2004-05-13 13:08:37 EDT
Please call 

/usr/sbin/alternatives --set mta /usr/sbin/sendmail.sendmail

There was an error in the old sendmail package.

Comment 3 Thomas Woerner 2004-05-13 13:08:50 EDT
*** Bug 123173 has been marked as a duplicate of this bug. ***
Comment 5 Christopher McCrory 2004-05-13 14:27:11 EDT
FWIW , this also breaks loks of perl libs that require /usr/lib/sendmail

/usr/sbin/alternatives --set mta /usr/sbin/sendmail.sendmail fixes
them too.



Thanks Thomas!


Comment 6 Holger Eilhard 2004-05-14 12:12:23 EDT
Have the corresponding sendmail RPM(s) been removed, including the
errata? Can't find it on RHN...
Comment 7 John Flanagan 2004-05-18 15:09:17 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-221.html

Note You need to log in before you can comment on or make changes to this bug.