Bug 123216 - apache segfaults on mod_auth_pgsql protected location access
apache segfaults on mod_auth_pgsql protected location access
Status: CLOSED DUPLICATE of bug 150087
Product: Fedora
Classification: Fedora
Component: mod_auth_pgsql (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-13 17:19 EDT by Martin Frey
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 03:21:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frey 2004-05-13 17:19:57 EDT
Description of problem:
When accessing a directory protected with mod_auth_pgsql
authentication the new apache child segfaults.

Version-Release number of selected component (if applicable):
httpd: 2.0.48-1.2
mod_auth_pqsql: 2.0.1
postgresql-libs: 7.3.4.11
openssl: 0.9.7a-33.10
glibc: 2.3.2-101.4
kernel-smp: 2.4.22-1.2188.nptl

postgresql-server: 7.3.4-3.rhl9 (running on a remote RH9 box)  
The server is not configured to use SSL encryption.

How reproducible:

Using the configuration below the newly forked
apache child segfaults.
Entry in /var/log/httpd/error_log:
[Thu May 13 22:47:53 2004] [notice] child pid 30750 exit signal 
Segmentation fault (11)

<Location /test>
        Auth_PG_host 192.168.200.36
        Auth_PG_port 5432
        Auth_PG_database users
        Auth_PG_user apache
        Auth_PG_pwd PASSWORD
        Auth_PG_pwd_table passwd
        Auth_PG_grp_table groups
        Auth_PG_uid_field username
        Auth_PG_pwd_field pwd_crypt
        Auth_PG_hash_type CRYPT
        Auth_PG_nopasswd off
        AuthType Basic
        AuthName "test"
        require valid-user
</Location>

I recompiled mod_auth_pgsql from the RH9 SRPM (0.9.12-14)
and installed the resulting RPM. That works without
problems.

Steps to Reproduce:
1.Setup apache with above test directory on FC1, use
  DB (I have the DB on a remote RH9 node)
2. Access directory
3. Check log
  
Actual results:
Segfault of server child after entering the password
in the browser

Expected results:
No segfault

Additional info:
System is a 2 GB dual Xeon P4 box.
Comment 1 Joe Orton 2006-01-09 03:21:43 EST

*** This bug has been marked as a duplicate of 150087 ***

Note You need to log in before you can comment on or make changes to this bug.