Bug 150087 - useage of mod_auth_pgsql causes segfaults in httpd
Summary: useage of mod_auth_pgsql causes segfaults in httpd
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_auth_pgsql   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
: 123216 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-02 13:21 UTC by Mirko Streckenbach
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 08:23:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that removes the segmentation faults (629 bytes, patch)
2005-03-02 13:23 UTC, Mirko Streckenbach
no flags Details | Diff

Description Mirko Streckenbach 2005-03-02 13:21:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
We have multiple machines using this module for authentification.
On some it worked flawless and on some it caused segmentation faults
all the time, and on some it produced log messages like

mod_auth_pgsql: Password for user (null) not found (PG-Authoritative)

and did not work.


Inspection of the code showed that the module accessed the "user"
field of the request structure passed to the module before having
ensured, that this field is initialized. In some setups this field
might have been initialized by a different module before, so this
bug does not always occur.


A patch that fixes the problem is attached.




Version-Release number of selected component (if applicable):
mod_auth_pgsql-2.0.1-6

How reproducible:
Sometimes

Steps to Reproduce:
Depends on the machine.

Actual Results:  Crashes of http

Expected Results:  No Crash


Additional info:

Comment 1 Mirko Streckenbach 2005-03-02 13:23:27 UTC
Created attachment 111565 [details]
Patch that removes the segmentation faults

Comment 2 Joe Orton 2005-04-04 12:13:35 UTC
Thanks for the patch.

Comment 3 Joe Orton 2006-01-09 08:21:51 UTC
*** Bug 123216 has been marked as a duplicate of this bug. ***

Comment 4 Joe Orton 2006-01-09 08:23:25 UTC
Fixed in current updates, thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.