Bug 1232172 - Disperse volume : 'ls -ltrh' doesn't list correct size of the files every time
Summary: Disperse volume : 'ls -ltrh' doesn't list correct size of the files every time
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1228525
Blocks: 1223636 1234679
TreeView+ depends on / blocked
 
Reported: 2015-06-16 08:46 UTC by Pranith Kumar K
Modified: 2016-06-16 13:12 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1228525
: 1234679 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:12:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-16 08:49:25 UTC
REVIEW: http://review.gluster.org/11246 (cluster/ec: wind fops on good subvols for access/readdir[p]) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-06-22 16:16:12 UTC
REVIEW: http://review.gluster.org/11246 (cluster/ec: wind fops on good subvols for access/readdir[p]) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2015-06-23 01:03:34 UTC
REVIEW: http://review.gluster.org/11246 (cluster/ec: wind fops on good subvols for access/readdir[p]) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Anand Avati 2015-06-26 07:25:48 UTC
COMMIT: http://review.gluster.org/11246 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 5485cb1b2e9b68a9746acc08289aaadb2cfe11c4
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jun 15 16:32:06 2015 +0530

    cluster/ec: wind fops on good subvols for access/readdir[p]
    
    Change-Id: I1e629a6adc803c4b7164a5a7a81ee5cb1d0e139c
    BUG: 1232172
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11246
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>

Comment 5 Anand Avati 2015-07-02 09:28:33 UTC
REVIEW: http://review.gluster.org/11506 (cluster/ec: Remove locks in opendir) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Anand Avati 2015-07-06 11:00:44 UTC
REVIEW: http://review.gluster.org/11506 (cluster/ec: Remove locks in opendir) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 7 Anand Avati 2015-07-07 11:43:40 UTC
REVIEW: http://review.gluster.org/11506 (cluster/ec: Remove locks in opendir) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 8 Anand Avati 2015-07-08 07:06:34 UTC
COMMIT: http://review.gluster.org/11506 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 638febc61deb78c30bcecd147f3bc3df3d85e0fe
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Jul 2 09:26:44 2015 +0530

    cluster/ec: Remove locks in opendir
    
    With readdir[p] taking locks to figure out which bricks are
    good/bad, no need to take any locks on opendir.
    
    BUG: 1232172
    Change-Id: I4d924aeeaecab23af08c4598548a20d2a44cd849
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11506
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 9 Anand Avati 2015-07-09 05:13:34 UTC
REVIEW: http://review.gluster.org/11589 (cluster/ec: wind readlink on good subvol(s)) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 10 Anand Avati 2015-07-09 10:25:20 UTC
REVIEW: http://review.gluster.org/11589 (cluster/ec: wind readlink on good subvol(s)) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 11 Anand Avati 2015-07-14 11:14:42 UTC
COMMIT: http://review.gluster.org/11589 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 7766c0df5509e8acb6768c69d3f5642909781135
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Jul 1 14:25:07 2015 +0530

    cluster/ec: wind readlink on good subvol(s)
    
    BUG: 1232172
    Change-Id: I3a56e487840d86147dd85bf5fbe79b165eae289f
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11589
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 12 Mike McCune 2016-03-28 23:18:47 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 13 Niels de Vos 2016-06-16 13:12:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.