Bug 1234679 - Disperse volume : 'ls -ltrh' doesn't list correct size of the files every time
Summary: Disperse volume : 'ls -ltrh' doesn't list correct size of the files every time
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1228525 1232172
Blocks: 1223636
TreeView+ depends on / blocked
 
Reported: 2015-06-23 02:52 UTC by Pranith Kumar K
Modified: 2015-07-30 09:47 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1232172
Environment:
Last Closed:
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-23 03:32:04 UTC
REVIEW: http://review.gluster.org/11357 (cluster/ec: wind fops on good subvols for access/readdir[p]) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-07-02 00:19:21 UTC
REVIEW: http://review.gluster.org/11357 (cluster/ec: wind fops on good subvols for access/readdir[p]) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2015-07-16 03:27:10 UTC
REVIEW: http://review.gluster.org/11684 (cluster/ec: Remove locks in opendir) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Anand Avati 2015-07-16 03:27:19 UTC
REVIEW: http://review.gluster.org/11687 (cluster/ec: wind readlink on good subvol(s)) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Anand Avati 2015-07-21 11:56:21 UTC
REVIEW: http://review.gluster.org/11684 (cluster/ec: Remove locks in opendir) posted (#2) for review on release-3.7 by Xavier Hernandez (xhernandez@datalab.es)

Comment 6 Anand Avati 2015-07-21 11:57:17 UTC
REVIEW: http://review.gluster.org/11687 (cluster/ec: wind readlink on good subvol(s)) posted (#2) for review on release-3.7 by Xavier Hernandez (xhernandez@datalab.es)

Comment 7 Anand Avati 2015-07-21 21:43:46 UTC
COMMIT: http://review.gluster.org/11684 committed in release-3.7 by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 53aa618c55a6a8e3e6eff78bea6399f079da35a6
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Jul 2 09:26:44 2015 +0530

    cluster/ec: Remove locks in opendir
    
    With readdir[p] taking locks to figure out which bricks are
    good/bad, no need to take any locks on opendir.
    
     >BUG: 1232172
     >Change-Id: I4d924aeeaecab23af08c4598548a20d2a44cd849
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/11506
     >Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
     >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
     >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    BUG: 1234679
    Change-Id: Ibada9c196fb44a38400ef027f0a3a142d32797a6
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11684
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>

Comment 8 Kaushal 2015-07-30 09:47:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Kaushal 2015-07-30 09:47:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Kaushal 2015-07-30 09:47:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.