Bug 1232363 - Puppet: "Import" dropdown runs off the side of the screen, is unreadable/discernible.
Summary: Puppet: "Import" dropdown runs off the side of the screen, is unreadable/dis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tomas Strachota
QA Contact: Sachin Ghai
Russell Dickenson
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-06-16 14:43 UTC by Corey Welton
Modified: 2019-06-13 21:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Issue: When you navigate to Configure > Puppet Classes and click "Import", the labels in the drop-down list may be cut off at the edge of the browser's window, making it impossible to confirm in advance what is being selected. Resizing the browser's window has no effect on the problem. Workaround: None at this time.
Clone Of:
Environment:
Last Closed: 2015-09-15 07:22:10 UTC


Attachments (Terms of Use)
screenshot (13.07 KB, image/png)
2015-06-16 14:45 UTC, Corey Welton
no flags Details
on puppet classes page, import dropdown properly shows all menu items (73.21 KB, image/png)
2015-09-01 09:32 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1786 normal SHIPPED_LIVE Satellite 6.1.2 bug fix update 2015-09-15 11:20:04 UTC
Foreman Issue Tracker 11111 None None None 2016-04-22 16:46:56 UTC

Description Corey Welton 2015-06-16 14:43:08 UTC
Description of problem:
User cannot read the menu items in the Import menu and from where they are cut off, they read identical and can't be differentiated.

Version-Release number of selected component (if applicable):

Compose 8 snap 3

How reproducible:


Steps to Reproduce:
1. Configure > Puppet Classes > Import
2. View results


Actual results:
The text is cut off in the dropdown, off the side of the screen, and the choices are ambiguous.

Expected results:
Readability/able to properly select the correct menu item, know which is which

Additional info:

Comment 1 Corey Welton 2015-06-16 14:45:51 UTC
Created attachment 1039508 [details]
screenshot

Attached screenshot.  Please note that this happens regardless as to whether browser is maximized, etc.

Comment 3 Bryan Kearney 2015-07-14 20:04:35 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11111 has been closed
-------------
Anonymous
Applied in changeset commit:cc67119632ea77bde23415abe1691f8297df8132.

Comment 7 Sachin Ghai 2015-09-01 09:30:58 UTC
Verified with sat6.1.2 SNAP1

I can see the menu items properly with import dropdown from puppet classes page.
 Please see the screenshot for verification.

Comment 8 Sachin Ghai 2015-09-01 09:32:32 UTC
Created attachment 1068904 [details]
on puppet classes page, import dropdown properly shows all menu items

Comment 10 errata-xmlrpc 2015-09-15 07:22:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1786


Note You need to log in before you can comment on or make changes to this bug.