Bug 123255 - vncviewer Segmentation fault
Summary: vncviewer Segmentation fault
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc   
(Show other bugs)
Version: 2
Hardware: athlon Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 131357 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-14 20:32 UTC by Son To
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 14:51:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from gdb --args vncviewer localhost:1 (1.03 KB, text/plain)
2004-06-06 13:11 UTC, Dave Atkinson
no flags Details
Output of chkconfig --list xfs + others (1.21 KB, text/plain)
2004-06-07 23:43 UTC, Dave Atkinson
no flags Details

Description Son To 2004-05-14 20:32:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
vncviewer crashes all the time. never got it to work. It doesn't
matter what version of vncserver I try to connect to.  Connecting to
my rh9 system running vnc-server-3.3.3r2-47 crashes vncviewer. So I
thought it could be a version problem, but connecting to a fedora core
1 vnc-server-4.0-0.beta4.3.2 system also crashes vncviewer.

Here's an example:

[son@localhost son]$ vncviewer localhost:1
 
VNC viewer for X version 4.0b4 - built Nov 17 2003 13:17:08
Copyright (C) 2002-2003 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Segmentation fault



Version-Release number of selected component (if applicable):
vnc-4.0-0.beta4.3.2

How reproducible:
Always

Steps to Reproduce:
1. vncserver
2. vncviewer localhost:1

step 2 assumes vncserver is running on display 1. change it   
appropriately
    

Additional info:

Comment 1 Tim Waugh 2004-05-15 09:06:14 UTC
Please install vnc-debuginfo-4.0-0.beta4.3.2:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/debug/vnc-debuginfo-4.0-0.beta4.3.2.i386.rpm

and run vncviewer like this:

gdb --args vncviewer localhost:1
(gdb) run
...
(gdb) bt

and tell me what it says.

Comment 2 Dave Atkinson 2004-06-06 13:11:15 UTC
Created attachment 100904 [details]
Output from gdb --args vncviewer localhost:1

This is the result of running gdb --args vncviewer localhost:1 on my system:
Dual PIII 550, 512MB, scsi, 2.4.22-1.2188.nptlsmp smp, XFree86 4.3.0-55, ATI
Radeon 9200LE

Comment 3 Dave Atkinson 2004-06-06 14:19:28 UTC
Okay, I installed the source, too.  It seems to crap out on line 73/4
of tx/TXWindow.cxx: 

defaultFS = 
  XLoadQueryFont(dpy, "-*-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*");

On the next line, the returned value is used as a pointer,

defaultFont = defaultFS -> fid;

 but defaultFS is NULL, hence the crash.  So for some reason, I don't
have "-*-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*" on my system.  I can
provide a list of the font packages I've installed, if required.  I
assume the fix is to use a font that does exist, but I know nowt about
X font programming, so I'll have to look this one up.  Over to you guys?

Comment 4 Tim Waugh 2004-06-07 10:08:22 UTC
What does '/sbin/chkconfig --list xfs' say?

Yes, the fix will be to fall back to something else, but I'd like to
be sure about the reason the first choice isn't working.

Comment 5 Dave Atkinson 2004-06-07 23:43:09 UTC
Created attachment 100949 [details]
Output of chkconfig --list xfs + others

I've put the output of the command requested in the attachment, along with some
other info that may be useful.

Comment 6 Tim Waugh 2004-06-24 15:01:58 UTC
So according to xlsfonts the font request ought to have been granted,
since you have fonts that match!

So it's still a bit of a mystery that it failed in the first place. 
But besides, I have seen situations in which that particular font
pattern can't be provided, so perhaps it should fall back to 'fixed'.

Comment 7 Tim Waugh 2004-08-31 17:37:00 UTC
*** Bug 131357 has been marked as a duplicate of this bug. ***

Comment 8 Jonas Printzen 2004-09-08 11:06:10 UTC
Hi!

I have exactly the same problem. But additional info.
It used to work a few months ago. I constantly update
packages I think important using yum or up2date.
=> Some update breaks some font aspect?

Also!! 
I can still connect to my server from windows-client.
And if I then start vncviewer from there ... It works!

Clarification:
  Running vncviewer when the X-environment is vncserver
  appears to work!

Running fc2 with updates on my server and workstation.
Both behave the same. Machine is P4 (i686)

/Jonas

Comment 9 Tim Waugh 2004-09-13 16:40:57 UTC
Please try the test update for FC2 announced here:

http://www.redhat.com/archives/fedora-test-list/2004-September/msg00049.html

Does that fix the problem?

Comment 10 Patrice Dumas 2004-09-17 11:05:35 UTC
I had exactly the same segfault after I upgraded xorg to
xorg-x11-6.7.99.903, and it is solved by the update which works
for me. I have apentium III.

Comment 11 Ted Kaczmarek 2004-10-02 11:04:25 UTC
Looks good with vnc-4.0-5, thanks a bunch.


Note You need to log in before you can comment on or make changes to this bug.