Bug 131357 - Segmentation fault when starting
Segmentation fault when starting
Status: CLOSED DUPLICATE of bug 123255
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 10:53 EDT by Ted Kaczmarek
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2004-08-31 10:53:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040612 Firefox/0.8

Description of problem:
Seg fault when trying to start

Version-Release number of selected component (if applicable):
vnc-4.0-1.beta4.11

How reproducible:
Always

Steps to Reproduce:
1.try launching vncviewer
2.
3.
    

Actual Results:  Seg fault

Expected Results:  Connect to remote display

Additional info:

A clean fc2 install.

Program received signal SIGSEGV, Segmentation fault.
0x08064296 in ?? ()
(gdb) bt
#0  0x08064296 in ?? ()
#1  0x08063431 in ?? ()
#2  0x00243ad4 in __libc_start_main () from /lib/tls/libc.so.6
#3  0x0804bfe1 in ?? ()
(gdb)
Comment 1 Tim Waugh 2004-08-31 10:56:38 EDT
What does 'rpm -V vnc-server' say, and does 'prelink -u /usr/bin/Xvnc'
help?
Comment 2 Ted Kaczmarek 2004-08-31 11:02:27 EDT
[root@cr1lapted root]# rpm -V vnc-server
package vnc-server is not installed
[root@cr1lapted root]# prelink -u /usr/bin/Xvnc
prelink: cannot open "/usr/bin/Xvnc": No such file or directory
[root@cr1lapted root]#

Comment 3 Tim Waugh 2004-08-31 11:07:19 EDT
Oh, it's the viewer you're using?

Well then try:

rpm -V vnc

and:

prelink -U /usr/bin/vncviewer
Comment 4 Ted Kaczmarek 2004-08-31 11:13:01 EDT
[root@cr1lapted root]# rpm -V vnc
[root@cr1lapted root]# prelink -U /usr/bin/vncviewer
prelink: invalid option -- U
Try `prelink --help' or `prelink --usage' for more information.
[root@cr1lapted root]# prelink -u /usr/bin/vncviewer
prelink: /usr/bin/vncviewer does not have .gnu.prelink_undo section
[root@cr1lapted root]#rpm -q policy
policy-1.11.3-3

Taking a guess this is where we are heading :-)
Comment 5 Tim Waugh 2004-08-31 11:17:19 EDT
I don't think this is selinux-related.

Please install the debuginfo package from here:

http://download.fedora.redhat.com/pub/fedora/linux/core/2/i386/debug/vnc-debuginfo-4.0-1.beta4.11.i386.rpm

and launch vncviewer from the command line like this:

gdb vncviewer

Then at the (gdb) prompt type 'run' and press enter.  Then, once it
crashes and puts you back at the (gdb) prompt, type 'bt' and press
enter: what does it say?
Comment 6 Ted Kaczmarek 2004-08-31 12:11:49 EDT
[tkaczmar@cr1lapted tkaczmar]$ gdb vncviewer
GNU gdb Red Hat Linux (6.0post-0.20040223.19rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging
symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
                                                                     
                                           
(gdb) run
Starting program: /usr/bin/vncviewer
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...
VNC viewer for X version 4.0b4 - built Apr 14 2004 12:25:22
Copyright (C) 2002-2003 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x08064296 in ?? ()
(gdb) bt
#0  0x08064296 in ?? ()
#1  0x08063431 in ?? ()
#2  0x00243ad4 in __libc_start_main () from /lib/tls/libc.so.6
#3  0x0804bfe1 in ?? ()
(gdb)

Comment 7 Tim Waugh 2004-08-31 12:22:04 EDT
That looks like you don't have the correct package installed.  What
does this say?:

rpm -q vnc vnc-debuginfo
rpm -ql vnc-debuginfo
Comment 8 Ted Kaczmarek 2004-08-31 13:21:48 EDT
[root@cr1lapted root]# rpm -q vnc vnc-debuginfo
vnc-4.0-1.beta4.11
package vnc-debuginfo is not installed

Arg, got the debug package from kickstart.

Program received signal SIGSEGV, Segmentation fault.
TXWindow::init (dpy=0x85be4b0) at TXWindow.cxx:75
75        defaultFont = defaultFS->fid;
(gdb) bt
#0  TXWindow::init (dpy=0x85be4b0) at TXWindow.cxx:75
#1  0x08063431 in main (argc=1, argv=0xfeea0e04) at vncviewer.cxx:307
#2  0x00243ad4 in __libc_start_main () from /lib/tls/libc.so.6
#3  0x0804bfe1 in _start ()

Ok, looks simillar to bug 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123255
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=127134

[root@cr1lapted root]# /sbin/chkconfig --list xfs
xfs             0:off   1:off   2:on    3:on    4:on    5:on    6:off
root@cr1lapted root]# service xfs status
xfs (pid 2168) is running...

I looked into trying vnc-4.0-4.i386.rpm, but it needs libstdc++.so.6,
which libstdc++-3.4.1-9.i386.rpm provides but does not satisfy deps
for anything requiring libstdc++.so.5. 

Have a dev box that I can try this on, but it is closer to FC3 test
than it is to FC2 though. I will try and update this bug if that is of
any value.





Comment 9 Tim Waugh 2004-08-31 13:36:53 EDT
Bug #127134 is an Xvnc crash and not related.  This does, however,
look exactly like bug #123255.

Marking as duplicate.

Please hold off upgrading, since there is a VNC update for FC2 in the
works.

*** This bug has been marked as a duplicate of 123255 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:05:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.