Bug 1232889 - Snapshot: When Cluster.enable-shared-storage is enable, shared storage should get mount after Node reboot
Summary: Snapshot: When Cluster.enable-shared-storage is enable, shared storage should...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.1
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1231223 1231876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 18:11 UTC by Avra Sengupta
Modified: 2015-07-30 09:50 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1231876
Environment:
Last Closed: 2015-07-30 09:50:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-17 18:12:45 UTC
REVIEW: http://review.gluster.org/11295 (gluster/shared_storage: Add/Remove shared storage from /etc/fstab during enable/disable) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-06-24 09:13:20 UTC
COMMIT: http://review.gluster.org/11295 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 1fc5308f1157fe1cbcd60313e09d66be71c2d051
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Jun 17 15:00:23 2015 +0530

    gluster/shared_storage: Add/Remove shared storage from /etc/fstab during enable/disable
    
        Backport of http://review.gluster.org/#/c/11272/
    
    While creating/deleting shared storage volume, add/remove the shared storage
    entry from /etc/fstab, so as to ensure availability of the shared storage,
    even after a node reboot
    
    Change-Id: Ib9edc8fd02c74a677062ca53ffd10be997b056c6
    BUG: 1232889
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11295
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Kaushal 2015-07-30 09:50:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.