Bug 123289 - boot failed Kernel 2.4.9-e.40smp, megaraid_2002 Dell
boot failed Kernel 2.4.9-e.40smp, megaraid_2002 Dell
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-15 19:44 EDT by Mark Henson
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 18:02:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Henson 2004-05-15 19:44:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506

Description of problem:
https://rhn.redhat.com/network/errata/details/index.pxt?eid=2082&r=97680

Details updates to MegaRAID2.  These updates break Dell RAID controller:

08:08.0 RAID bus controller: Dell Computer Corporation PowerEdge
Expandable RAID controller 4 (rev 01)

Normal kernel boot messages are:

SCSI subsystem driver Revision: 1.00
megaraid: v2.00.2 (Release Date: Wed Dec  4 14:34:51 EST 2002)
megaraid: found 0x1028:0x000e:bus 8:slot 8:func 0
scsi0:Found MegaRAID controller at 0xf8830000, IRQ:72
megaraid: [2.27:1.04] detected 1 logical drives.
megaraid: supports extended CDBs.
megaraid: channel[0] is raid.
megaraid: channel[1] is scsi.
scsi0 : LSI Logic MegaRAID 2.27 254 commands 16 targs 5 chans 7 luns
blk: queue f79f2e18, I/O limit 4095Mb (mask 0xffffffff)
scsi0: scanning scsi channel 0 for logical drives.
  Vendor: MegaRAID  Model: LD0 RAID1 34678R  Rev: 2.27
  Type:   Direct-Access                      ANSI SCSI revision: 02
blk: queue c2128218, I/O limit 4095Mb (mask 0xffffffff)
scsi0: scanning scsi channel 1 for logical drives.
scsi0: scanning scsi channel 2 for logical drives.
scsi0: scanning scsi channel 4 [P0] for physical devices.
  Vendor: PE/PV     Model: 1x6 SCSI BP       Rev: 1.1
  Type:   Processor                          ANSI SCSI revision: 02
blk: queue f73dc818, I/O limit 4095Mb (mask 0xffffffff)
scsi0: scanning scsi channel 5 [P1] for physical devices.
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 71020544 512-byte hdwr sectors (36363 MB)
Partition check:
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 >
(scsi1) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI
2/2/0
(scsi1) Wide Channel A, SCSI ID=7, 32/255 SCBs
(scsi1) Downloading sequencer code... 396 instructions downloaded
(scsi2) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI
2/2/1
(scsi2) Wide Channel B, SCSI ID=7, 32/255 SCBs
(scsi2) Downloading sequencer code... 396 instructions downloaded
scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.5/5.2.0
       <Adaptec AIC-7899 Ultra 160/m SCSI host adapter>
scsi2 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.5/5.2.0
       <Adaptec AIC-7899 Ultra 160/m SCSI host adapter>
blk: queue f7357a18, I/O limit 4095Mb (mask 0xffffffff)
  Vendor: ARCHIVE   Model: Python 06408-XXX  Rev: 9050
  Type:   Sequential-Access                  ANSI SCSI revision: 03


When boot fails it is not possible to read the attempt to load the
driver however root FS fails to mount:

request_module[block-major-8]: Root fs not mounted
VFS: Cannot open root device "sda2" or 08:02
Please append correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:02
                                                                     
          



Version-Release number of selected component (if applicable):
LSI megaraid2 v2.10.1.1

How reproducible:
Always

Steps to Reproduce:
1. Set Grub to boot 2.4.9-e.40smp
2. Reboot machine 
3. Root FS fails to mount
    

Actual Results:  Machine fails to boot.

Expected Results:  See text above - MegaRaid driver should have loaded
normally and detected sda.

Additional info:
Comment 1 Mark Henson 2004-05-15 19:49:15 EDT

*** This bug has been marked as a duplicate of 75090 ***
Comment 3 Tom Coughlan 2004-05-17 12:51:21 EDT
I am reopenning this bug.  I do not think it is a duplicate of 75090.
Comment 4 Tom Coughlan 2004-05-17 12:59:14 EDT
Please check your /etc/modules.conf file.  If there is an entry for
the megaraid_2002 driver, then remove this line and replace it with
"megaraid2".  Then try the upgrade again.  The megaraid_2002 driver
was removed in U4.
Comment 5 Mark Henson 2004-05-19 17:45:58 EDT
Current /etc/modules.conf

alias parport_lowlevel parport_pc
alias scsi_hostadapter megaraid_2002
alias eth0 e1000
alias scsi_hostadapter1 aic7xxx
alias scsi_hostadapter2 aic7xxx
alias scsi_hostadapter3 aic7xxx
alias usb-controller usb-uhci

Will test changing megaraid_2002 to megaraid2 - however this must be
done out of hours so it may take a couple of days to test.
Comment 6 Mark Henson 2004-06-02 12:48:46 EDT
Ok, have tested change from megaraid_2002 to megaraid2 and we have the
same result.  when booting 2.4.9-e.38smp with this driver (megaraid2)
everything works perfectly.  If neccesary I can setup to capture the
boot messages by serial.  

The behaviour of megaraid2 is unchanged from megaraid_2002
Comment 7 Jason Baron 2004-06-02 13:25:49 EDT
after editing /etc/modules.conf, did you re-install the  kernel rpm?
The 'initrd' needs to pick up the change in /etc/modules.conf, and a
re-install of the kernel rpm will pick that up. 
Comment 9 Mark Henson 2004-06-25 17:46:16 EDT
Thanks.  Changes noted here have worked with RH latest kernel.

Mark

Note You need to log in before you can comment on or make changes to this bug.