Bug 75090 - [PATCH] autodetect the megaraid driver for the PERC4 RAID card
[PATCH] autodetect the megaraid driver for the PERC4 RAID card
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kudzu (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks: 113478
  Show dependency treegraph
Reported: 2002-10-04 06:57 EDT by Yasuma Takeda
Modified: 2014-03-16 22:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-06-28 15:54:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
megaraid v1.18d driver patch (27.47 KB, patch)
2002-10-04 07:08 EDT, Yasuma Takeda
no flags Details | Diff
pcitable-megaraid2.patch (788 bytes, text/plain)
2004-06-10 08:40 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Yasuma Takeda 2002-10-04 06:57:30 EDT
Description of problem:
Installer can't find PERC4 RAID device on DELL PE2600.
PERC4 RAID needs megaraid v1.18a.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Try to install RedHat Advanced Server 2.1 to    
  DELL PowerEdge2600.


Additional info:
Comment 1 Yasuma Takeda 2002-10-04 07:08:52 EDT
Created attachment 78587 [details]
megaraid v1.18d driver patch
Comment 2 Pierre Amadio 2003-10-17 05:41:47 EDT
A workaround that worked here (on a machine installed correctly using previous
ernel) was to install the kernel 2.4.9-e.27smp , changing the megaraid alias
entry in /etc/modules.conf to megaraid_2002, then create a new initrd disk.  
Comment 3 Elliot Peele 2004-05-07 17:49:16 EDT
This still doesn't work in U3 or U4. Is there any chance of this
getting fixed?

I have a couple of Dell 1750s that have this card in them and
installing is a tad painfull since I have to use the original AS2.1
disks to do an install since the megaraid driver from Dell is built
for it and not U4. I am trying to set these machines up to be proxy
servers since the proxy server requires AS2.1.
Comment 4 Mark Henson 2004-05-15 19:49:18 EDT
*** Bug 123289 has been marked as a duplicate of this bug. ***
Comment 5 Tom Coughlan 2004-05-17 14:57:59 EDT

I need a bit more detail on "the megaraid driver from Dell is built
for (the original AS2.1) and not U4".  

In AS2.1 we ship both the megaraid v1.18 driver and various versions
of the megaraid v2 driver. The v1.18 driver is the default, and has
not changed since the original AS2.1.  If it worked for you then, it
should still be working.

Support for new hadrware (like certain PERC4 models) and on-going
maintenance has been put in to the v2 driver. If you need this driver,
then you need to select it manually during the install process (the
noprobe option).

Please let me know more specifically where you are having trouble. 

Comment 6 Elliot Peele 2004-05-17 15:28:27 EDT
Dell supplies a megaraid v2 driver disk compiled for the original
release of AS2.1. I was not aware that the megaraid v2 driver was
shipped in U4. The version that Dell provides is 2.10.1. Is this
available in AS2.1?
Comment 7 Tom Coughlan 2004-05-17 17:25:10 EDT
Yes, AS 2.1 U4 has (one more bug fix than Dell's :^).

Comment 8 Bastien Nocera 2004-06-10 08:39:24 EDT
The problem is that kudzu/anaconda still tries to use the (plain, v1)
megaraid driver for that newer card.
Patch attached below.
Comment 9 Bastien Nocera 2004-06-10 08:40:54 EDT
Created attachment 101026 [details]

Autodetect that the PERC4 needs the megaraid 2 driver.
Comment 10 Bastien Nocera 2004-06-10 08:42:38 EDT
And reassign.
Comment 11 Bill Nottingham 2004-06-28 15:54:48 EDT
This will cause multiple sets of problems:

1) you can't load both drivers on the same box. Ergo, if you have both
kinds of cards, you'll get a system crash.
2) if you upgrade to a later release, you won't be using the default
driver for later releases.

Ergo, this is best handled manually for now.
Comment 12 John Flanagan 2004-12-13 15:06:22 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.