Bug 1233255 - ppc64le hosts should support only 3.6+ compatibility level
Summary: ppc64le hosts should support only 3.6+ compatibility level
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Polednik
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks: 1201508 RHEV3.6PPC
TreeView+ depends on / blocked
 
Reported: 2015-06-18 14:35 UTC by Michal Skrivanek
Modified: 2016-03-09 19:41 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.6.0-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 19:41:35 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC

Description Michal Skrivanek 2015-06-18 14:35:54 UTC
since ppc64le support is only introduced in 3.6 we plan to only support a 3.6 compatibility level. There's no point to support anything lower than that as there is no earlier vdsms and 3.4/3.5 ppc64 is not compatible either

Comment 1 Ilanit Stein 2015-10-08 12:11:09 UTC
How this bug should be verified please?

Comment 2 Michal Skrivanek 2015-10-08 12:34:22 UTC
you shouldn't be able to run in 3.5 compatibility level for ppc64le clusters, only 3.6

Comment 3 Ilanit Stein 2015-10-08 13:48:54 UTC
Verified with these flows:

1. Adding a new rhel 7.2 based ppc host to a datacenter/cluster 3.5 compatibility level for ppc64le fail during installation with these events:

Host host_mixed_1 is compatible with versions (3.6) and cannot join Cluster ilanit which is set to version 3.5.

Host host_mixed_1 moved to Non-Operational state as host CPU type is not supported in this cluster compatibility version or is not supported at all

2. Trying to change rhel 7.2 based ppc host cluster from 3.6 ppc cluster to 3.5 ppc cluster fail on:

Operation cancelled
Error while executing action: 

host_mixed_2:
Host CPU type is not supported in this cluster compatibility version or is not supported at all.

**Comment:
It is though possible to add a 3.5 compatibility level for ppc64le clusters.

Comment 6 errata-xmlrpc 2016-03-09 19:41:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.