Bug 1233273 - 'unable to get transaction op-info' error seen in glusterd log while executing gluster volume status command
Summary: 'unable to get transaction op-info' error seen in glusterd log while executin...
Keywords:
Status: CLOSED DUPLICATE of bug 1249461
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.1
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1238936 1249461
TreeView+ depends on / blocked
 
Reported: 2015-06-18 15:03 UTC by SATHEESARAN
Modified: 2015-08-12 04:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1238936 (view as bug list)
Environment:
Last Closed: 2015-08-12 04:41:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description SATHEESARAN 2015-06-18 15:03:13 UTC
Description of problem:
-----------------------
While executing 'gluster volume status' command, the following error message was seen,

<snip>
[2015-06-18 15:16:40.377993] E [glusterd-op-sm.c:251:glusterd_get_txn_opinfo] (--> /usr/lib64/libglusterfs.so.0(_gf_log_callingfn+0x1e0)[0x7fc835252fc0] (--> /usr/lib64/glusterfs/3.7.1/xlator/mgmt/glusterd.so(glusterd_get_txn_opinfo+0x197)[0x7fc829c80d67] (--> /usr/lib64/glusterfs/3.7.1/xlator/mgmt/glusterd.so(__glusterd_handle_stage_op+0x1f0)[0x7fc829c611a0] (--> /usr/lib64/glusterfs/3.7.1/xlator/mgmt/glusterd.so(glusterd_big_locked_handler+0x3f)[0x7fc829c5e53f] (--> /usr/lib64/libglusterfs.so.0(synctask_wrap+0x12)[0x7fc8352935f2] ))))) 0-management: Unable to get transaction opinfo for transaction ID : c1d215cb-2b61-4ad4-828a-643f634a9e98
</snip>


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHEL 6.7 Beta + glusterfs-3.7.1

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Create a volume of any type and start it
2. Execute 'gluster volume status' command
3. Check glusterd logs

Actual results:
---------------
Error messages as described earlier in the description was seen

Expected results:
-----------------
There shouldn't be any error messages

Comment 1 SATHEESARAN 2015-06-18 15:04:48 UTC
I was managing gluster nodes in oVirt, which uses 'gluster volume status' periodically to get the status/health of the gluster node

As a result, the error messages as indicated in comment0 gets filled all over the glusterd logs.

Comment 2 Atin Mukherjee 2015-08-12 04:41:55 UTC

*** This bug has been marked as a duplicate of bug 1249461 ***


Note You need to log in before you can comment on or make changes to this bug.