Bug 1238936 - 'unable to get transaction op-info' error seen in glusterd log while executing gluster volume status command
Summary: 'unable to get transaction op-info' error seen in glusterd log while executin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1233273
Blocks: 1249461
TreeView+ depends on / blocked
 
Reported: 2015-07-03 06:24 UTC by Atin Mukherjee
Modified: 2016-06-16 13:19 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1233273
: 1249461 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:19:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2015-07-03 06:24:44 UTC
+++ This bug was initially created as a clone of Bug #1233273 +++

Description of problem:
-----------------------
While executing 'gluster volume status' command, the following error message was seen,

<snip>
[2015-06-18 15:16:40.377993] E [glusterd-op-sm.c:251:glusterd_get_txn_opinfo] (--> /usr/lib64/libglusterfs.so.0(_gf_log_callingfn+0x1e0)[0x7fc835252fc0] (--> /usr/lib64/glusterfs/3.7.1/xlator/mgmt/glusterd.so(glusterd_get_txn_opinfo+0x197)[0x7fc829c80d67] (--> /usr/lib64/glusterfs/3.7.1/xlator/mgmt/glusterd.so(__glusterd_handle_stage_op+0x1f0)[0x7fc829c611a0] (--> /usr/lib64/glusterfs/3.7.1/xlator/mgmt/glusterd.so(glusterd_big_locked_handler+0x3f)[0x7fc829c5e53f] (--> /usr/lib64/libglusterfs.so.0(synctask_wrap+0x12)[0x7fc8352935f2] ))))) 0-management: Unable to get transaction opinfo for transaction ID : c1d215cb-2b61-4ad4-828a-643f634a9e98
</snip>


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHEL 6.7 Beta + glusterfs-3.7.1

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Create a volume of any type and start it
2. Execute 'gluster volume status' command
3. Check glusterd logs

Actual results:
---------------
Error messages as described earlier in the description was seen

Expected results:
-----------------
There shouldn't be any error messages

--- Additional comment from SATHEESARAN on 2015-06-18 11:04:48 EDT ---

I was managing gluster nodes in oVirt, which uses 'gluster volume status' periodically to get the status/health of the gluster node

As a result, the error messages as indicated in comment0 gets filled all over the glusterd logs.

Comment 1 Anand Avati 2015-07-03 06:26:48 UTC
REVIEW: http://review.gluster.org/11520 (glusterd: Do not log failure if glusterd_get_txn_opinfo fails in gluster volume status) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2015-08-03 04:31:25 UTC
COMMIT: http://review.gluster.org/11520 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit aa80be0501a6893564b0dd40611cc91ad553ca6c
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Fri Jul 3 11:34:20 2015 +0530

    glusterd: Do not log failure if glusterd_get_txn_opinfo fails in gluster volume status
    
    The first RPC call of gluster volume status fetches the list of the volume names
    from GlusterD and during that time since no volume name is set in the dictionary
    gluserd_get_txn_opinfo fails resulting into a failure log which is annoying to
    the user considering this command is triggered frequently.
    
    Fix is to have callers log it depending on the need
    
    Change-Id: Ib60a56725208182175513c505c61bcb28148b2d0
    BUG: 1238936
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/11520
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 15:10:28 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:19:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.