Bug 123339 - sata_sil module can not be used because siimage is built-in
sata_sil module can not be used because siimage is built-in
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 07:29 EDT by Paul Jakma
Modified: 2013-07-02 22:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 04:03:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Jakma 2004-05-17 07:29:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Galeon/1.3.10

Description of problem:
See also bug #123338. The siimage driver appears slightly unreliable,
also sata_sil apparently offers better performance. Hence I would like
to try it and test it. However, I dont see how the sata_sil module can
be used because the siimage driver is compiled in and will always have
claimed the hardware. Using, eg, ide0=noprobe has no effect. I've
looked through the siimage driver and do not see any kernel command
line argument to pass through to disable either.

Could there be some way to disable a built-in IDE driver? Or better,
could the IDE drivers be built modular and loaded in initrd like
everything else?

Hardware is:

Compaq Deskpro 4000N 5233MMX
Silicon Image Sil3112A controller
Western Digital WDC1600 SATA disk drive


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel
2. Watch Siimage init
3. When userspace is running, try modprobe sata_sil and watch it do
nothing.
    

Actual Results:  sata_sil prints its version to kernel log, but doesnt
discover any hardware, because siimage is compiled in.

Expected Results:  there should be some way to disable siimage, or
else siimage should be built modular to allow user to be able to use
sata_sil should they so desire.

Additional info:
Comment 1 Arjan van de Ven 2004-05-17 07:31:08 EDT
modular ide is a really big can of worms; we're not going to do that.
Option is to whack the SATA pci id out of the siimage driver though....
Comment 2 Alan Cox 2004-05-21 20:14:42 EDT
I agree with this. The siimage driver would need to remain for the 680
but the 3112 is a unique PCI id so its worth doing. It probably ought
to be done upstream
Comment 3 Paul Jakma 2005-01-11 20:14:10 EST
This issue appears to be fixed in later FC2 and FC3 kernels. I've been
happily running stock kernels for a while now. Dont know how you fixed
it, but thanks!

Note You need to log in before you can comment on or make changes to this bug.