Bug 1234042 - ERROR : Error appeared during Puppet run: 192.168.122.82_api_nova.pp Error: Use of reserved word: type, must be quoted if intended to be a String value at /var/tmp/packstack/811663aa10824d21b860729732c16c3a/manifests/192.168.122.82_api_nova.pp:41:3
ERROR : Error appeared during Puppet run: 192.168.122.82_api_nova.pp Error: U...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Kilo
x86_64 Linux
unspecified Severity urgent
: ---
: Kilo
Assigned To: Gaël Chamoulaud
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-20 09:23 EDT by Udayendu Kar
Modified: 2016-04-18 02:47 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-packstack-2015.1-0.5.dev1565.gd1211af.fc23 openstack-puppet-modules-2015.1.6-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:10:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Setup logs. (7.61 KB, text/plain)
2015-06-20 09:23 EDT, Udayendu Kar
no flags Details
openstack-setup.log.gz ( trace of mentioned failure ) during packstack run (2.14 KB, application/x-gzip)
2015-06-21 07:40 EDT, Boris Derzhavets
no flags Details

  None (edit)
Description Udayendu Kar 2015-06-20 09:23:16 EDT
Created attachment 1041175 [details]
Setup logs.

Description of problem:
packstack --allinone setup failed with the below error message:

---
ERROR : Error appeared during Puppet run: 192.168.122.82_api_nova.pp
Error: Use of reserved word: type, must be quoted if intended to be a String value at /var/tmp/packstack/811663aa10824d21b860729732c16c3a/manifests/192.168.122.82_api_nova.pp:41:3
---

Version-Release number of selected component (if applicable):
Fedora 22 Server x86_64
OpenStack-kilo


How reproducible:
100%

Steps to Reproduce:
1. Follow all the steps as mentioned in https://www.rdoproject.org/Quickstart
2. Just need to use F22 as for F11 there are lots of package dependencies issue available.


Actual results:
Installation failed with puppet error

Expected results:
It should work fine

Additional info:
RDO repo is also not maintained properly. From F21 repo we are getting packages for F22 & F23. And same for the latest repo as mentioned in https://www.rdoproject.org/Quickstart . This documentation need modification.
Comment 1 Boris Derzhavets 2015-06-21 07:18:23 EDT
Experiencing same issue during AIO RDO Kilo install on Fedora 22
Comment 2 Boris Derzhavets 2015-06-21 07:40:35 EDT
Created attachment 1041401 [details]
openstack-setup.log.gz  ( trace of mentioned failure ) during packstack run

Trace of packstack failure uploaded
Comment 3 Boris Derzhavets 2015-06-21 16:33:43 EDT
Workaround 1

Update /usr/lib/python2.7/site-packages/packstack/puppet/templates/nova_common_rabbitmq.pp as follows :-
  'type' => hiera('NOVA_MIGRATION_KEY_TYPE'),
  'type' => hiera('NOVA_MIGRATION_KEY_TYPE'),

Restarted packstack, next failed IP_neutron.pp.

Workaround 2

Insert as second row into /usr/share/openstack-puppet/modules/vswitch/lib/puppet/provider/vs_port/ovs-redhat.rb following line :-

require File.expand_path(File.join(File.dirname(__FILE__), '.','ovs.rb'))

Restarted packstack, next failed IP_horizon.pp.

I stopped to fix errors and tested via Nova&&Neutron CLI AIO Kilo instance on F22.  I was able to create external and private sub-nets, neutron router, gateway to ext and interface to private sub-net and load via nova boot Cirros 0.3.3 instance.Logged in with floating IP using injected ssh key,verified acess to :-
1. Nova-metadata server - OK
2. Internet - OK ( like `curl http:\\lxer.com` and `ping 8.8.8.8`)
Comment 4 Boris Derzhavets 2015-06-22 04:55:23 EDT
Filed against versions :-

[root@ip-192-169-142-57 ~]# rpm -qa \*puppet\*
openstack-puppet-modules-2015.1.2-1.fc23.noarch
openstack-packstack-puppet-2015.1-0.2.dev1537.gba5183c.fc23.noarch
puppet-4.1.0-1.fc22.noarch
Comment 5 Boris Derzhavets 2015-06-23 06:26:41 EDT
Workaround 2 related with auto loading parents stable shows up on old box
Q9550 based and slow DDR3 memory and doesn't show up on box with i7 47XX Haswell CPU and DDR3 memory 1866 MHZ Kingston, SATA 3 Drives
Comment 6 Boris Derzhavets 2015-06-25 04:26:04 EDT
(In reply to Boris Derzhavets from comment #3)
> Workaround 2
> 
> Insert as second row into
> /usr/share/openstack-puppet/modules/vswitch/lib/puppet/provider/vs_port/ovs-
> redhat.rb following line :-
> 
> require File.expand_path(File.join(File.dirname(__FILE__), '.','ovs.rb'))
> 

In meantime on any box IP_neutron.pp fails due to failure auto load parent ovs_redhat, correspondent fix is inserting as first line:-
 
require File.expand_path(File.join(File.dirname(__FILE__), '.','ovs_redhat.rb') 

into ovs_redhat_el6.rb
Comment 7 Alan Pevec 2015-07-23 17:24:29 EDT
> From F21 repo we are getting packages for F22 & F23.

That's correct, Fedora RDO repo is delivering updated package builds from the newer Fedoras, %{dist} reflects that. Builds are noarch so they work fine on older Fedora.
Comment 8 Gaël Chamoulaud 2015-08-04 11:27:48 EDT
Well, after some test trying to reproduce your issues, it seems all of these have been already fixed:

- Workaround 1: 
Update /usr/lib/python2.7/site-packages/packstack/puppet/templates/nova_common_rabbitmq.pp as follows :-
  'type' => hiera('NOVA_MIGRATION_KEY_TYPE'),
  'type' => hiera('NOVA_MIGRATION_KEY_TYPE'),

Fix included with commit https://github.com/stackforge/packstack/commit/1c0c36bf40879435e17c1701dbc2927b8dfd4699
Fix included in openstack-packstack-2015.1-0.5.dev1565.gd1211af.fc23

- Workaround 2:
Insert as second row into /usr/share/openstack-puppet/modules/vswitch/lib/puppet/provider/vs_port/ovs-redhat.rb following line :-

require File.expand_path(File.join(File.dirname(__FILE__), '.','ovs.rb'))

Fix included in openstack-puppet-modules-2015.1.6-2.fc23
Comment 9 Boris Derzhavets 2015-08-04 12:35:03 EDT
In meantime `dnf -y install openstack-packstack` installs on Fedora 22
openstack-puppet-modules-2015.1.9-4.fc23.noarch.
I've analyzed corresponding corresponding :-
openstack-puppet-modules-2015.1.9-4.el7.src.rpm 
openstack-puppet-modules-2015.1.9-3.fc23.src.rpm
Comment 10 Boris Derzhavets 2015-08-04 12:45:57 EDT
I believe in meantime we have new issue :-
https://bugzilla.redhat.com/show_bug.cgi?id=1249482
Comment 11 Boris Derzhavets 2015-08-05 04:50:39 EDT
UPDATE for Comment 6

Insert as first line :- 
require File.expand_path(File.join(File.dirname(__FILE__),'.','ovs_redhat.rb')) 
into ovs_redhat_el6.rb

Note You need to log in before you can comment on or make changes to this bug.