Bug 1234286 - changelog: directory renames not getting recorded
Summary: changelog: directory renames not getting recorded
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milind Changire
QA Contact:
URL:
Whiteboard:
: 1234282 (view as bug list)
Depends On:
Blocks: 1223636 1234282 1235236 1235242
TreeView+ depends on / blocked
 
Reported: 2015-06-22 09:51 UTC by Milind Changire
Modified: 2016-06-16 13:14 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1235236 1235242 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:14:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
Changelog parser for v1.2 (3.54 KB, text/x-python)
2015-06-22 09:51 UTC, Milind Changire
no flags Details

Description Milind Changire 2015-06-22 09:51:14 UTC
Created attachment 1041692 [details]
Changelog parser for v1.2

Description of problem:
Directory renames are not getting recorded


Version-Release number of selected component (if applicable):
v1.2


How reproducible:
Always


Steps to Reproduce:
1. create a volume vol1
2. mount vol1 at /mnt/vol1
3. cd /mnt/vol1
4. mkdir dir1
5. mv dir1 dir2      # wait for 20 seconds for changelog flush
6. on all of the bricks verify that changelogs don't have the
   RENAME <pgfid>/dir1 <pgfid>/dir2
   operation being logged


Actual results:
MKDIR dir1


Expected results:
MKDIR dir1
RENAME dir1 dir2


Additional info:
Changelogs at the bricks can be parsed using the attached python script for
changelog v1.2

Comment 1 Anand Avati 2015-06-22 11:13:40 UTC
REVIEW: http://review.gluster.org/11343 (changelog: directory renames not getting recorded) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)

Comment 2 Anand Avati 2015-06-22 12:15:53 UTC
REVIEW: http://review.gluster.org/11343 (changelog: directory renames not getting recorded) posted (#3) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 3 Anand Avati 2015-06-22 12:39:27 UTC
REVIEW: http://review.gluster.org/11343 (changelog: directory renames not getting recorded) posted (#4) for review on master by Milind Changire (mchangir@redhat.com)

Comment 4 Anand Avati 2015-06-23 05:08:11 UTC
REVIEW: http://review.gluster.org/11343 (changelog: directory renames not getting recorded) posted (#5) for review on master by Milind Changire (mchangir@redhat.com)

Comment 5 Saravanakumar 2015-06-23 14:29:36 UTC
Update:

Patch http://review.gluster.org/#/c/11356/ fixes this issue.

Comment 6 Anand Avati 2015-06-24 02:45:18 UTC
REVIEW: http://review.gluster.org/11356 (features/changelog: Always log directory rename operations) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 7 Milind Changire 2016-02-15 06:41:43 UTC
*** Bug 1234282 has been marked as a duplicate of this bug. ***

Comment 8 Niels de Vos 2016-06-16 13:14:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.