Bug 123454 - igmp packets generated with invalid cksums
igmp packets generated with invalid cksums
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: James Morris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 14:31 EDT by Ion Badulescu
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:55:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IP partial-checksum fix for x86_64 (353 bytes, patch)
2004-05-18 15:53 EDT, Ion Badulescu
no flags Details | Diff

  None (edit)
Description Ion Badulescu 2004-05-18 14:31:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
This is from tcpdump, when a native (64-bit) application attempts to
subscribe to a multicast group:

14:22:19.150000 10.0.30.20 > 224.0.0.22: igmp v3 report, 1 group
record(s) [gaddr 239.255.0.11 to_in { }] bad igmp cksum ebff! (DF)
[tos 0xc0]  [ttl 1] (id 0, len 40, optlen=4 RA)

I haven't tried a 32-bit application, so I don't know if it would work
or not. I strongly suspect it wouldn't.

The packet is obviously ignored by the receiving router(s), so the
application ends up not receiving any traffic.


Version-Release number of selected component (if applicable):
kernel-2.4.21-15.ELsmp and 2.4.21-9.0.3.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. run tcpdump -vvv -n igmp
2. run any multicast listener (routed/gated would do, but it's not
provided, zebra will probably do as well)
3.
    

Actual Results:  observe the bad igmp cksum message from tcpdump

Additional info:
Comment 1 Ion Badulescu 2004-05-18 15:51:35 EDT
Also look at:

http://lists.suse.com/archive/suse-amd64/2004-Feb/0322.html

for another instance of the same bug, and a proposed solution.

I tested that solution (attached below) and it seems to work for me.
Comment 2 Ion Badulescu 2004-05-18 15:53:28 EDT
Created attachment 100311 [details]
IP partial-checksum fix for x86_64
Comment 3 Mike Gahagan 2004-10-07 11:18:50 EDT

*** This bug has been marked as a duplicate of 131048 ***
Comment 4 Ernie Petrides 2004-10-07 16:16:38 EDT
A fix for this problem was committed to the RHEL3 U4 patch
pool on 14-Sep-2004 (in kernel version 2.4.21-20.6.EL).
Comment 5 John Flanagan 2004-12-20 15:55:16 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.