Bug 131048 - (IT_47809) Summary: Multicast broken on x86_64
Summary: Multicast broken on x86_64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Gahagan
Brian Brock
http://seclists.org/lists/linux-kerne...
:
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2004-08-26 17:41 EDT by Kevin W. Rudd
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:56:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x86_64 checksum fix. (365 bytes, patch)
2004-08-27 03:05 EDT, Don Howard
no flags Details | Diff

  None (edit)
Description Kevin W. Rudd 2004-08-26 17:41:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
There are checksum problems in the x86_64 environment that are keeping
multicast support from working properly.  This has been documented and
fixed in newer kernels.  The original linux-kernel thread and patch
can be found via the following URL:

http://seclists.org/lists/linux-kernel/2004/Feb/7006.html

Version-Release number of selected component (if applicable):
kernel-2.4.21-18.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. Run tcpdump or ethereal to capture igmp traffic
2. Join a multicast group.  For our test, we were joining 225.1.1.13.
3. Note the IGMP checksum
    
Actual Results:  The Membership Report packet sent had an incorrect
checksum:

Frame 12 (54 bytes on wire, 54 bytes captured)
Ethernet II, Src: 00:0d:60:53:04:47, Dst: 01:00:5e:00:00:16
Internet Protocol, Src Addr: 160.108.89.103 (160.108.89.103), Dst Addr:
224.0.0.22 (224.0.0.22)
Internet Group Management Protocol
    IGMP Version: 3
    Type: Membership Report (0x22)
    Header checksum: 0xf8fd (incorrect, should be 0xf7ef)
    Num Group Records: 1
    Group Record : 225.1.1.13  Change To Exclude Mode
        Record Type: Change To Exclude Mode (4)
        Aux Data Len: 0
        Num Src: 0
        Multicast Address: 225.1.1.13 (225.1.1.13)


Expected Results:  The checksum should be 0xf7ef for that particular
Membership Report.

Additional info:
Comment 2 Don Howard 2004-08-27 03:05:16 EDT
Created attachment 103154 [details]
x86_64 checksum fix.
Comment 5 Ernie Petrides 2004-09-14 20:10:56 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.6.EL).
Comment 6 Mike Gahagan 2004-10-07 11:19:02 EDT
*** Bug 123454 has been marked as a duplicate of this bug. ***
Comment 7 John Flanagan 2004-12-20 15:56:03 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.