Bug 1234613 - The overcloud_validate script is using run_tempest.sh where it should call tools/run-tests.sh
Summary: The overcloud_validate script is using run_tempest.sh where it should call to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: Director
Assignee: RHOS Maint
QA Contact: tkammer
URL:
Whiteboard:
: 1236073 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-22 20:13 UTC by wes hayutin
Modified: 2015-08-05 13:55 UTC (History)
13 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-14.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:55:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 237293 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description wes hayutin 2015-06-22 20:13:52 UTC
Description of problem:

Looking at https://github.com/rdo-management/python-rdomanager-oscplugin/blob/master/rdomanager_oscplugin/v1/overcloud_validate.py

overcloud_validate is using the wrong script to invoke tempest.  The correct script to execute is tools/run-tests.sh

https://github.com/redhat-openstack/tempest/blob/master/tools/run-tests.sh

dkranz can assist w/ the proper config and execution of tempest.

Comment 1 mathieu bultel 2015-06-22 21:49:05 UTC
I have submitted a patch on python-rdo-manager-oscplugin :
https://review.gerrithub.io/#/c/237293/

Comment 2 Dougal Matthews 2015-06-29 08:02:30 UTC
The change was merged midstream and presumably just needs to be submitted downstream?

Midstream commit: https://github.com/rdo-management/python-rdomanager-oscplugin/commit/9e10a840ac968c25fcffb367430b996a23669b53

Comment 3 Dougal Matthews 2015-06-29 12:36:29 UTC
Posted downstream https://code.engineering.redhat.com/gerrit/#/c/51860/

Comment 5 wes hayutin 2015-07-27 16:02:14 UTC
puddle is using:

mock_setup_dir.assert_called_once_with()
        mock_os_chdir.assert_called_with('/home/user/tempest')
        mock_run_shell.assert_has_calls([
            mock.call('/usr/share/openstack-tempest-kilo/tools/'
                      'configure-tempest-directory'),
            mock.call('./tools/config_tempest.py --out etc/tempest.conf '
                      '--deployer-input partial_config_file '
                      '--debug --create '
                      'identity.uri http://foo '
                      'compute.allow_tenant_isolation true '
                      'object-storage.operator_role SwiftOperator '
                      'identity.admin_password password '
                      'compute.build_timeout 500 '
                      'compute.image_ssh_user cirros '
                      'compute.ssh_user cirros '
                      'network.build_timeout 500 '
                      'volume.build_timeout 500 '
                      'scenario.ssh_user cirros'),
            mock.call('./tools/run-tests.sh bar --skip-file skip')
        ])

Comment 9 tkammer 2015-07-30 13:50:13 UTC
*** Bug 1236073 has been marked as a duplicate of this bug. ***

Comment 11 Omri Hochman 2015-07-30 19:38:51 UTC
Verified [stack@rhos-compute-node-18 ~]$ rpm -qa | grep python-rdomanager-oscplugin
python-rdomanager-oscplugin-0.0.8-43.el7ost.noarch


[stack@rhos-compute-node-18 ~]$ grep 'test' /usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_validate.py
        args = ['./tools/run-tests.sh', ]

Comment 13 errata-xmlrpc 2015-08-05 13:55:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.