Bug 1236073 - osp-director is using the wrong script to launch tempest
Summary: osp-director is using the wrong script to launch tempest
Keywords:
Status: CLOSED DUPLICATE of bug 1234613
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Imre Farkas
QA Contact: tkammer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-26 13:12 UTC by wes hayutin
Modified: 2016-09-20 05:03 UTC (History)
11 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-14.el7ost
Doc Type: Bug Fix
Doc Text:
The OpenStack Overcloud validate ran the OpenStack Integration Test Suite (tempest) as documented upstream instead of using a midstream tool in redhat-openstack/tempest, resulting in an output format that was different. With this update, the OpenStack Overcloud validate runs tempest using the midstream tool and the output format is as expected.
Clone Of:
Environment:
Last Closed: 2015-07-30 13:50:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 237293 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description wes hayutin 2015-06-26 13:12:17 UTC
Description of problem:

https://review.gerrithub.io/#/c/237293

Comment 1 Imre Farkas 2015-07-01 07:20:38 UTC
Just to clarify because I have seen some confusion about this bug: the "wrong" script is the one which is documented upstream to run tempest: http://docs.openstack.org/developer/tempest/overview.html

The bug is about switching to a wrapper script which was added to the midstream redhat-openstack/tempest repo adding some improvement over the upstream one.

Comment 3 tkammer 2015-07-30 13:50:12 UTC

*** This bug has been marked as a duplicate of bug 1234613 ***


Note You need to log in before you can comment on or make changes to this bug.