Bug 1234741 - [virtio-win][vioscsi]win2012 guest bsod(c9) when whql test DPWLK-HotAdd(1104) job
Summary: [virtio-win][vioscsi]win2012 guest bsod(c9) when whql test DPWLK-HotAdd(1104)...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-06-23 07:29 UTC by Yu Wang
Modified: 2016-11-04 08:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:46:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2015-06-23 07:29:11 UTC
Description of problem:
win2012 guest bsod(c9) when whql test DPWLK-HotAdd(1104) job

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.boot guest with:
/usr/libexec/qemu-kvm -name 105SCS2012645FH -enable-kvm -m 6G -smp 8 -uuid 18052249-f65e-4592-afb6-639b6c8c3730 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/105SCS2012645FH,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=105SCS2012645FH,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=105SCS2012645FH.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:05:1f:cd:e0,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7,num_queues=8 -drive file=105SCS2012645FH_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0

2.run whql test DPWLK-HotAdd(1104) job

Actual results:
bsod(c9)

Expected results:
Pass

Additional info:

kd> ! analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_VERIFIER_IOMANAGER_VIOLATION (c9)
The IO manager has caught a misbehaving driver.
Arguments:
Arg1: 0000000000000226, An IRP dispatch handler has returned without passing down or completing this IRP,
	or someone forgot to return STATUS_PENDING.
Arg2: fffff880016f3ed4, The address in the driver's code where the error was detected.
Arg3: fffff98005020d80, IRP address.
Arg4: 0000000000000000

Debugging Details:
------------------


BUGCHECK_STR:  0xc9_226

DRIVER_VERIFIER_IO_VIOLATION_TYPE:  226

FAULTING_IP: 
storport!RaDriverPnpIrp+0
fffff880`016f3ed4 4c8bdc          mov     r11,rsp

FOLLOWUP_IP: 
storport!RaDriverPnpIrp+0
fffff880`016f3ed4 4c8bdc          mov     r11,rsp

IRP_ADDRESS: fffff98005020d80

DEVICE_OBJECT: fffffa8007023050

DRIVER_OBJECT: fffffa80067ff540

IMAGE_NAME:  vioscsi.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  556eddd9

MODULE_NAME: vioscsi

FAULTING_MODULE: fffff88001093000 vioscsi

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  2

ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

LAST_CONTROL_TRANSFER:  from fffff8023cccdfa0 to fffff8023c702040

STACK_TEXT:  
fffff880`02f86208 fffff802`3cccdfa0 : 00000000`000000c9 00000000`00000226 fffff880`016f3ed4 fffff980`05020d80 : nt!KeBugCheckEx
fffff880`02f86210 fffff802`3ccd2771 : fffff802`3ccc0460 fffff880`016f3ed4 fffff980`05020d80 00000000`00000000 : nt!VerifierBugCheckIfAppropriate+0x3c
fffff880`02f86250 fffff802`3ccd01c5 : fffffa80`062b7ce0 fffff880`02f863a0 fffffa80`06207880 fffff880`016f3ed4 : nt!ViErrorFinishReport+0x105
fffff880`02f862a0 fffff802`3cccdd06 : fffffa80`062242b8 00000000`00000001 fffffa80`062b7ce0 fffff802`3cccf419 : nt!IovpCallDriver2+0x4d5
fffff880`02f86670 fffff802`3ccc4d3d : fffff980`05020d80 fffffa80`07023050 fffff980`05020d80 fffffa80`07022a20 : nt!VfAfterCallDriver+0x296
fffff880`02f86700 fffff802`3cce03e9 : fffff980`05020f28 fffffa80`07022a20 fffffa80`07023050 fffffa80`062b7ce0 : nt!IovCallDriver+0x3fd
fffff880`02f86750 fffff802`3ccc4d26 : fffffa80`07022b70 fffff980`05020d80 fffffa80`07022a20 00000000`00000002 : nt!ViFilterDispatchPnp+0x89
fffff880`02f86790 fffff880`00a0395a : 01d0a9a5`6ceb1860 00000000`00000004 fffff980`05020d80 fffffa80`062074a0 : nt!IovCallDriver+0x3e6
fffff880`02f867e0 fffff880`00a067f3 : fffffa80`070228b0 fffffa80`07022760 fffff980`05020d80 00000000`00000000 : MSDMFilt!FilterPassIrpSynchronouslyTimed+0xb6
fffff880`02f86850 fffff880`00a0560b : fffff980`05020d80 fffff980`05020fb8 fffff880`00a00000 fffff802`3cccda55 : MSDMFilt!FilterStop+0xff
fffff880`02f868a0 fffff802`3ccc4d26 : fffff980`05020d80 fffffa80`07022760 00000000`00000002 fffffa80`06218ca0 : MSDMFilt!FilterDispatchPnp+0x1bf
fffff880`02f868f0 fffff802`3ca0f337 : fffffa80`07022760 00000000`c00000bb 00000000`00000000 fffffa80`06218ca0 : nt!IovCallDriver+0x3e6
fffff880`02f86940 fffff802`3cbeb255 : fffffa80`067da880 00000000`00000000 00000000`00000000 00000000`00000004 : nt!IopSynchronousCall+0xc7
fffff880`02f869b0 fffff802`3cbd794a : 00000000`00000000 00000000`00000000 00000000`00000000 fffff802`3c78c9a5 : nt!IopQueryReconfiguration+0x9d
fffff880`02f86a40 fffff802`3cbd792b : fffffa80`067dc490 00000000`00000000 fffff8a0`01fd6000 00000000`00000000 : nt!PnpStopDeviceSubtree+0x3a
fffff880`02f86a70 fffff802`3cbd792b : fffffa80`067be7f0 00000000`00000000 00000000`00000000 fffff8a0`01fd6000 : nt!PnpStopDeviceSubtree+0x1b
fffff880`02f86aa0 fffff802`3cbd792b : fffffa80`056ac350 fffff8a0`00201d38 fffff8a0`01fd6000 00000000`00000000 : nt!PnpStopDeviceSubtree+0x1b
fffff880`02f86ad0 fffff802`3cbd792b : fffffa80`056ef800 fffff8a0`01fd6000 00000000`00000008 fffff880`02f86b68 : nt!PnpStopDeviceSubtree+0x1b
fffff880`02f86b00 fffff802`3cbd7e7a : fffff8a0`01fd6000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!PnpStopDeviceSubtree+0x1b
fffff880`02f86b30 fffff802`3c7f6d3e : fffffa80`056b1010 fffffa80`056b1010 fffffa80`07e1f100 fffffa80`081bf301 : nt!PnpRebalance+0x10a
fffff880`02f86bc0 fffff802`3c8575c6 : fffffa80`081bf360 00000000`00000000 00000000`00000000 00000000`00000000 : nt!PnpProcessRebalance+0xae
fffff880`02f86c10 fffff802`3c73a391 : fffffa80`056f5040 fffff802`3c78d4bc fffff802`3c95a6e0 fffff802`3c70b700 : nt! ?? ::FNODOBFM::`string'+0xcdee
fffff880`02f86cc0 fffff802`3c6a9521 : 00000000`00000000 00000000`00000080 fffff802`3c73a250 fffffa80`056f5040 : nt!ExpWorkerThread+0x142
fffff880`02f86d50 fffff802`3c6e7dd6 : fffff802`3c97d180 fffffa80`056f5040 fffffa80`056ee480 fffffa80`056d4040 : nt!PspSystemThreadStartup+0x59
fffff880`02f86da0 00000000`00000000 : fffff880`02f87000 fffff880`02f81000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  0xc9_226_VRF_IMAGE_vioscsi.sys

BUCKET_ID:  0xc9_226_VRF_IMAGE_vioscsi.sys

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:0xc9_226_vrf_image_vioscsi.sys

FAILURE_ID_HASH:  {b053759f-2e96-10db-71f7-364527d9a734}

Followup: MachineOwner

Comment 1 Yu Wang 2015-06-23 07:44:44 UTC
The memory.dump file is located at
http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/virtio-win/bug1234741/

Comment 3 Yu Wang 2015-06-23 07:51:21 UTC
kernel-debug-3.10.0-267.el7.x86_64
qemu-kvm-rhev-2.3.0-2.el7.x86_64
seabios-bin-1.7.5-9.el7.x86_64
virtio-win-prewhql-105

Comment 8 Vadim Rozenfeld 2015-07-30 10:52:47 UTC
Please re-check with drivers from build 107
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/107/win/virtio-win-prewhql-0.1-107-spec.zip

Comment 9 lijin 2015-09-11 05:25:36 UTC
change status to verified as build 109 scsi whql jobs all pass

Comment 10 Vadim Rozenfeld 2015-09-30 06:00:24 UTC
This bug is tightly coupled with https://bugzilla.redhat.com/show_bug.cgi?id=1210166 
Moving it to 7.3 as well.

Comment 12 Peixiu Hou 2016-07-04 06:39:24 UTC
Hit this issue with virtio-win-prewhql-120&121, system occurred BSOD when running job DP WLK-Hot-Replace-Device Test-Verify driver support for D3 power state

Steps as comment#0

Tried to test with virtio-1.0  --job failed 
Tried to test without virtio-1.0  --job failed

BSOD dump file has uploaded to follows location:
http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1234741/

Comment 14 Vadim Rozenfeld 2016-07-12 08:23:05 UTC
Should be fixed in build 122
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=503003

Comment 15 Yu Wang 2016-07-13 06:43:46 UTC
According to our vioscsi WHQL Test result for virtio-win-prewhql-120, this job has passed, so this bug has been fixed.

Change status to verified.

Thanks
Yu Wang

Comment 17 errata-xmlrpc 2016-11-04 08:46:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.