Bug 1235231 - unix domain sockets on Gluster/NFS are created as fifo/pipe
Summary: unix domain sockets on Gluster/NFS are created as fifo/pipe
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1244114 1244117 1244118
TreeView+ depends on / blocked
 
Reported: 2015-06-24 11:06 UTC by Niels de Vos
Modified: 2016-06-16 13:16 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1244114 1244117 1244118 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:16:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-06-24 11:06:29 UTC
Description of problem:
When creating a unix domain socket on a Gluster/NFS mountpoint, the socket gets created as a fifo/pipe instead of a socket.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
100%

Steps to Reproduce:
1. mount a gluster volume over NFS
2. create a socket, like: socat UNIX-LISTEN:$N0/not-a-fifo.socket -
3. check the type of the new socket with ls or stat

Actual results:
"stat -c %F" returns "fifo" instead of "socket".

Expected results:
"stat -c %F" should return "socket".

Additional info:
reported on IRC by teknologeek https://botbot.me/freenode/gluster/2015-06-22/?msg=42565428&page=3

Comment 1 Anand Avati 2015-06-24 11:07:56 UTC
REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#5) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2015-06-28 15:39:39 UTC
REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#6) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Anand Avati 2015-06-28 16:05:12 UTC
REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#7) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 4 Anand Avati 2015-06-28 19:41:27 UTC
REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#8) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 5 udo.giacomozzi 2015-07-09 12:07:27 UTC
Hi.

I'm experiencing the exact same problem with Gluster 3.5.2 (Debian Package) and it's preventing my HA Proxmox Containers to operate properly (see http://forum.proxmox.com/threads/22767-var-log-not-working-in-containers)

Is there any workaround or trick possible to avoid the problem?

Comment 6 Nagaprasad Sathyanarayana 2015-10-25 15:04:49 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 7 Niels de Vos 2016-06-16 13:16:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.