Bug 1244114 - unix domain sockets on Gluster/NFS are created as fifo/pipe
Summary: unix domain sockets on Gluster/NFS are created as fifo/pipe
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: 3.7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1235231
Blocks: glusterfs-3.7.3
TreeView+ depends on / blocked
 
Reported: 2015-07-17 07:45 UTC by Niels de Vos
Modified: 2015-07-30 09:50 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1235231
Environment:
Last Closed: 2015-07-30 09:50:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-07-17 07:45:14 UTC
+++ This bug was initially created as a clone of Bug #1235231 +++

Description of problem:
When creating a unix domain socket on a Gluster/NFS mountpoint, the socket gets created as a fifo/pipe instead of a socket.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
100%

Steps to Reproduce:
1. mount a gluster volume over NFS
2. create a socket, like: socat UNIX-LISTEN:$N0/not-a-fifo.socket -
3. check the type of the new socket with ls or stat

Actual results:
"stat -c %F" returns "fifo" instead of "socket".

Expected results:
"stat -c %F" should return "socket".

Additional info:
reported on IRC by teknologeek https://botbot.me/freenode/gluster/2015-06-22/?msg=42565428&page=3

--- Additional comment from Anand Avati on 2015-06-24 13:07:56 CEST ---

REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#5) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-28 17:39:39 CEST ---

REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#6) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-28 18:05:12 CEST ---

REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#7) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-28 21:41:27 CEST ---

REVIEW: http://review.gluster.org/11355 (nfs: a unix-domain-socket should not be created as fifo) posted (#8) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from  on 2015-07-09 14:07:27 CEST ---

Hi.

I'm experiencing the exact same problem with Gluster 3.5.2 (Debian Package) and it's preventing my HA Proxmox Containers to operate properly (see http://forum.proxmox.com/threads/22767-var-log-not-working-in-containers)

Is there any workaround or trick possible to avoid the problem?

Comment 1 Anand Avati 2015-07-17 08:00:40 UTC
REVIEW: http://review.gluster.org/11708 (nfs: a unix-domain-socket should not be created as fifo) posted (#1) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2015-07-23 16:01:59 UTC
COMMIT: http://review.gluster.org/11708 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 2815a8c778fb6c17c6dfe908a82e840687c29a98
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Jul 17 09:51:16 2015 +0200

    nfs: a unix-domain-socket should not be created as fifo
    
    Cherry picked from commit 381afd4f480533f212e1f62a0ccfd9dcf7248e17:
    > Change-Id: Ic6a23165df1703b330636a059967c3c674dbde57
    > BUG: 1235231
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/11355
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: Ic6a23165df1703b330636a059967c3c674dbde57
    BUG: 1244114
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/11708
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Kaushal 2015-07-30 09:50:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.