Bug 123529 - Synaptics touchpad doesn't allow 'tapping' any more
Synaptics touchpad doesn't allow 'tapping' any more
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 00:41 EDT by Darryl Dixon
Modified: 2015-01-04 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 18:02:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl Dixon 2004-05-19 00:41:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The 'tap-to-click' function of the laptop's built-in synaptics
touchpad no longer works.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1.Install FC1 on IBM R40 laptop - Synaptics touchpad tap-to-click works
2.Upgrade to FC2 - Synaptics touchpad tap-to-click no longer works
3.Boot FC2 with old kernel-2.4.22-1.2188.nptl - Synaptics touchpad
tap-to-click works again.

    

Actual Results:  Touchpad no longer allows tapping on it to 'click' on
things.

Expected Results:  Tapping should replicate a 'click' with the left
mouse button

Additional info:

System is an IBM R40 laptop with builtin Synaptics touchpad and
TrackPoint button.  Output of dmesg with 2.6 kernel is:
[...]
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
Synaptics Touchpad, model: 1
 Firmware: 5.9
 Sensor: 44
 new absolute packet format
 Touchpad has extended capability bits
 -> multifinger detection
 -> palm detection
 -> pass-through port
input: SynPS/2 Synaptics TouchPad on isa0060/serio1
serio: Synaptics pass-through port at isa0060/serio1/input0
input: PS/2 Generic Mouse on synaptics-pt/serio0
serio: i8042 KBD port at 0x60,0x64 irq 1
[...]
Comment 1 Dave Arter 2004-05-19 17:02:19 EDT
I also experienced the same problem, and found 2 solutions:

1. Add 'psmouse.proto=imps' to kernel options in /boot/grub/grub.conf'
2. Install latest version of synaptic driver for X from
http://w1.894.telia.com/~u89404340/touchpad/

While solution 1 worked for me, it made the mouse very 'choppy' and
unresponsive.
Solution 2 works flawlessly, and even enables some extra features such
as scroll wheel emulation.
Comment 2 Darryl Dixon 2004-05-19 18:54:26 EDT
Thanks, I can confirm that adding the psmouse.proto=imps line does
indeed allow the touchpad to use tap-to-click once again with the 2.6
kernel.  Unfortunately, a side effect is that it disables the
trackpoint button (TrackPoint is the little finger-joystick style
mouse embedded in the keyboard).  I'll probably try the newer driver
mentioned above too; but the issue still stands of why this works in
2.4 but not 2.6...  :-)
Comment 3 Darin May 2004-05-27 15:11:53 EDT
Dupe of bug 122014 ?
Comment 4 Arjan van de Ven 2004-06-09 06:00:29 EDT
Can people on this bug please try the latest 424 kernel from
http://people.redhat.com/arjanv/2.6 
it has a bunch of touchpad fixes, including one that's supposed to
make tapping work again
Comment 5 Darryl Dixon 2004-06-09 18:39:12 EDT
Hi, I have tried kernel-2.6.6-1.424, unfortunately the behaviour of
the touchpad is not fixed; tapping still does not work.

Cheers,
D
Comment 6 Mauri Sahlberg 2004-06-11 11:59:57 EDT
I would be happy if synaptics touchpad worked even without tapping but
it does not work at all. It worked with FC 1 and works with Knoppix
but is completely ignored by 2.6-kernels including 2.6.6-247.

usbcore: registered new driver hiddev
usbcore: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
i8042.c: Detected active multiplexing controller, rev 1.9.
serio: i8042 AUX0 port at 0x60,0x64 irq 12
serio: i8042 AUX1 port at 0x60,0x64 irq 12
serio: i8042 AUX2 port at 0x60,0x64 irq 12
serio: i8042 AUX3 port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
Comment 7 Darin May 2004-07-06 14:30:40 EDT
Here's my dmesgs data wiht the 2.6.6-1.435.2.3 kernel, tapping still
not working:

mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
Synaptics Touchpad, model: 1
 Firmware: 4.3
 180 degree mounted touchpad
 Sensor: 8
 new absolute packet format
input: SynPS/2 Synaptics TouchPad on isa0060/serio1
Comment 8 Darryl Dixon 2004-11-15 18:02:45 EST
This can probably now be closed as it is fixed in FC3

Note You need to log in before you can comment on or make changes to this bug.