Bug 1235543 - Upcall: Directory or file creation should send cache invalidation requests to parent directories
Summary: Upcall: Directory or file creation should send cache invalidation requests to...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: upcall
Version: 3.7.2
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On: 1235542 1235544 1236274
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-25 06:51 UTC by Soumya Koduri
Modified: 2016-02-05 11:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1235542
Environment:
Last Closed: 2016-02-05 11:27:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Soumya Koduri 2015-06-25 06:51:50 UTC
+++ This bug was initially created as a clone of Bug #1235542 +++

Description of problem:
Any directory or file creation should result in cache-invalidation requests sent to parent directory. However that is not the case currently due to a bug while processing these requests in the upcall xlator. We need to do invalidation checks on parent inode.


Note You need to log in before you can comment on or make changes to this bug.