Bug 1235921 - POSIX: brick logs filled with _gf_log_callingfn due to this==NULL in dict_get
Summary: POSIX: brick logs filled with _gf_log_callingfn due to this==NULL in dict_get
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Raghavendra Talur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1235923 1235940
TreeView+ depends on / blocked
 
Reported: 2015-06-26 05:44 UTC by Raghavendra Talur
Modified: 2016-06-16 13:17 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1235923 1235940 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:17:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Talur 2015-06-26 05:44:52 UTC
Description of problem:


We see frequent logging of messages like

[2015-06-24 14:08:13.989147] I [dict.c:467:dict_get]
(--> /lib64/libglusterfs.so.0(_gf_log_callingfn+0x186)[0x7f02d7cf7ef6]
(--> /lib64/libglusterfs.so.0(dict_get+0x90)[0x7f02d7cf0ce0]
(--> /usr/lib64/glusterfs/3.7.2/xlator/storage/posix.so(posix_setxattr
+0x1b9)[0x7f02ca48a439] (--> /lib64/libglusterfs.so.0(default_setxattr
+0x75)[0x7f02d7cfc3a5]
(--> /usr/lib64/glusterfs/3.7.2/xlator/features/changetimerecorder.so(ctr_setxattr+0x186)[0x7f02c9a42696] ))))) 0-dict: !this || key=dht-get-iatt-in-xattr

Comment 1 Raghavendra Talur 2015-06-26 12:13:45 UTC
Patch posted at http://review.gluster.org/#/c/11390/

Comment 2 Anand Avati 2015-07-18 17:29:15 UTC
COMMIT: http://review.gluster.org/11390 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit a00c623dc1aa2df7e374d05f8a2ceaf205e854b6
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Jun 25 02:18:42 2015 +0530

    storage/posix: Check xdata for NULL before dict_get
    
    Performing a dict_get on xdata can lead to
    frequent logging if xdata is NULL.
    
    Change-Id: I1666f0cc958c639ccd816e3738dd4a1efebbff82
    BUG: 1235921
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/11390
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Mike McCune 2016-03-28 23:30:47 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 4 Niels de Vos 2016-06-16 13:17:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.