Bug 1235923 - POSIX: brick logs filled with _gf_log_callingfn due to this==NULL in dict_get
Summary: POSIX: brick logs filled with _gf_log_callingfn due to this==NULL in dict_get
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Raghavendra Talur
QA Contact:
URL:
Whiteboard:
Depends On: 1235921 1235940
Blocks: glusterfs-3.7.3
TreeView+ depends on / blocked
 
Reported: 2015-06-26 05:59 UTC by Raghavendra Talur
Modified: 2015-07-30 09:51 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1235921
Environment:
Last Closed: 2015-07-30 09:51:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Talur 2015-06-26 05:59:43 UTC
+++ This bug was initially created as a clone of Bug #1235921 +++

Description of problem:


We see frequent logging of messages like

[2015-06-24 14:08:13.989147] I [dict.c:467:dict_get]
(--> /lib64/libglusterfs.so.0(_gf_log_callingfn+0x186)[0x7f02d7cf7ef6]
(--> /lib64/libglusterfs.so.0(dict_get+0x90)[0x7f02d7cf0ce0]
(--> /usr/lib64/glusterfs/3.7.2/xlator/storage/posix.so(posix_setxattr
+0x1b9)[0x7f02ca48a439] (--> /lib64/libglusterfs.so.0(default_setxattr
+0x75)[0x7f02d7cfc3a5]
(--> /usr/lib64/glusterfs/3.7.2/xlator/features/changetimerecorder.so(ctr_setxattr+0x186)[0x7f02c9a42696] ))))) 0-dict: !this || key=dht-get-iatt-in-xattr

Comment 1 Anand Avati 2015-06-26 06:22:08 UTC
REVIEW: http://review.gluster.org/11417 (storage/posix: Check xdata for NULL before dict_get) posted (#1) for review on release-3.7 by Raghavendra Talur (rtalur@redhat.com)

Comment 2 Raghavendra Talur 2015-06-26 12:15:04 UTC
Patch posted on http://review.gluster.org/#/c/11417/

Comment 3 Anand Avati 2015-06-27 03:48:58 UTC
COMMIT: http://review.gluster.org/11417 committed in release-3.7 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 0b1ded9bbd1b20f20e2e68850c38c5b8b14b6292
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Jun 25 02:18:42 2015 +0530

    storage/posix: Check xdata for NULL before dict_get
    
             Backport of http://review.gluster.org/#/c/11390
    
    Performing a dict_get on xdata can lead to
    frequent logging if xdata is NULL.
    
    Change-Id: I1666f0cc958c639ccd816e3738dd4a1efebbff82
    BUG: 1235923
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/11417
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 4 Kaushal 2015-07-30 09:51:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.