Bug 1235939 - Provide and use a common way to do reference counting of (internal) structures
Summary: Provide and use a common way to do reference counting of (internal) structures
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1228157
Blocks: 1226717 1235628
TreeView+ depends on / blocked
 
Reported: 2015-06-26 07:00 UTC by Raghavendra G
Modified: 2015-07-30 09:48 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Enhancement
Doc Text:
Clone Of: 1228157
Environment:
Last Closed: 2015-07-30 09:48:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra G 2015-06-26 07:00:29 UTC
+++ This bug was initially created as a clone of Bug #1228157 +++

Description of problem:
Many structures need reference counting, and each structure implements its own way of doing it. This is confusing and makes things more difficult to understand than it necessary.

Version-Release number of selected component (if applicable):
mainline

I am not a grape farmer:
http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/11202

--- Additional comment from Anand Avati on 2015-06-04 06:48:57 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "struct gf_ref" for common refcounting strutures) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-04 06:49:46 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "gf_ref_t" for common refcounting structures) posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-04 07:19:00 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "gf_ref_t" for common refcounting structures) posted (#5) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-04 09:45:13 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "gf_ref_t" for common refcounting structures) posted (#6) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-04 19:15:08 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "gf_ref_t" for common refcounting structures) posted (#7) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-16 15:58:00 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "gf_ref_t" for common refcounting structures) posted (#8) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-16 16:03:23 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "gf_ref_t" for common refcounting structures) posted (#9) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-17 05:29:26 EDT ---

REVIEW: http://review.gluster.org/11022 (core: add "gf_ref_t" for common refcounting structures) posted (#10) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 1 Anand Avati 2015-06-26 17:01:13 UTC
REVIEW: http://review.gluster.org/11421 (core: add "gf_ref_t" for common refcounting structures) posted (#3) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijaikumar Mallikarjuna 2015-06-27 07:39:07 UTC
Patch merged: http://review.gluster.org/#/c/11421/

Comment 3 Kaushal 2015-07-30 09:48:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.