Bug 123612 - Upgrade includes non-existant SCSI drivers in modprobe.conf
Upgrade includes non-existant SCSI drivers in modprobe.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 13:12 EDT by Shahms E. King
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 00:12:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
modprobe.conf (with scsi_hostadapter) (591 bytes, text/plain)
2004-05-19 22:45 EDT, Shahms E. King
no flags Details

  None (edit)
Description Shahms E. King 2004-05-19 13:12:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
Upgrading a system from FC1 with an "alias scsi_hostadapter tmscsim"
line in modules.conf causes that same line to be included in
modprobe.conf even though the driver no longer exists.  This causes
mkinitrd to fail, which, in turn, causes 'new-kernel-pkg' to fail
meaning the grub configuration is not updated, leaving the system
unbootable.

The problem also occurs with the "initio" driver (and I assume any
SCSI driver that is no longer supported in 2.6).

Ideally anaconda or which ever post-install script is responsible for
migrating modules.conf to modprobe.conf would ensure that all SCSI
drivers specified are present in the shipped 2.6 kernel and either
leave them out entirely or comment them out.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC1 with a DC390 SCSI Adapter.
2. Upgrade to FC2.
    

Actual Results:  After the upgrade is complete, grub attempts to boot
a non-existant 2.4 kernel.

Expected Results:  The unsupported SCSI adapter is ignored or removed
and grub is properly updated allowing a normal boot.

Additional info:
Comment 1 Gérard Milmeister 2004-05-19 13:38:47 EDT
I had exactly the same problem but with the Initio module. I had to
boot rescue, remove any traces of initio in the /etc config files, and
perform new-kernel-pkg manually. This is PITA, I was able to do it,
but any less knowledgeable than I would be left with an unusable system.
Comment 2 Jeremy Katz 2004-05-19 22:32:21 EDT
Bill -- does kudzu make sure the module exists before writing the
scsi_hostadapter line?

Shahms -- can you attach /etc/modprobe.conf* from your system?
Comment 3 Shahms E. King 2004-05-19 22:45:31 EDT
Created attachment 100366 [details]
modprobe.conf (with scsi_hostadapter)

Jeremy, here is my modprobe.conf.  Note that I've upgraded to 2.6.6.-1.370 w/
the tmscsim module enabled.
Comment 4 Bill Nottingham 2004-05-24 17:37:04 EDT
kudzu checks.

The modules.conf -> modprobe.conf migrator does not.

Are these modules replaced with something? Or did the driver just Go Away?
Comment 5 Shahms E. King 2004-05-24 17:50:05 EDT
As I've filed in bug #123616 it's simply not built because it wasn't
ported to 2.6 until relatively late (2.6.0-rc3 last time I checked). 
It does, however, work as well or better than some SCSI adapters that
are included.
Comment 6 Bill Nottingham 2004-05-25 11:53:45 EDT
Assigning to kernel for the driver enablement.
Comment 7 Jeremy Katz 2004-05-25 23:20:27 EDT
At the same time, the module convertor probably needs to be smarter
about handling this too...
Comment 8 Dave Jones 2005-01-11 00:12:19 EST
similar problem to #142692 ?

we lacked the module_upgrade calls in the spec until recently too, which
probably didn't help things.

anyways, dc390t is now built.

Note You need to log in before you can comment on or make changes to this bug.